Automatic login using EPiServer's login form

Hello, We have an intranet where we use basic authentication to handle logging in to the application. We are using the login page taken from the EPiServer sample site with just some changes to the design. Everything works fine, except that the customer claim that the "automatic login" isn't working as they expect it to do. They still have to enter their login credentials at some occasions. I'm actually experiencing that same "problem" now and then here at EPiServer's Knowledge Center, even if I choose "Remember me", I still have to enter my credentials now and then. Does anyone else experience this or have any ideas about what might cause this problem? I've looked at the cookie for on my machine and it seems to be ok, it's set to expire 10 years from now, but somehow the cookie "disappears" now and then. Best regards Martin
May 21, 2007 16:23
Oops, just realized that I had mixed the concepts a bit in my first post. Of course we are using forms authentication, not basic authentication as I wrote in my post. /Martin
May 23, 2007 15:07
I have seen this now and then, but havent been able to reproduce it in a controlled environment. Are there any other cookies being set for the site? There is a maximum length allowed for cookies, and if this is exceeded, I suppose that the logincookie might be lost or get truncated. for example has cookies for Google Analytics, Vizzit and possible some more besides the forms authentication ticket, and I suppose that depending on their order of appearance in the http request might be of importance. I recommend you to use a sniffer to minitor the Http request being sent to the server from the client whe this situation occurs the next time and inspect the request looking for the cookiecollection and see if the .EPiServerLogin cookie is truncated. The above thoughts are just that: thoughts, and may have nothing to do with the problem at all. Best regards, Johan Olofsson EPiServer AB
May 23, 2007 16:10
For your amusement, I too have experienced this on many occasions, and it puzzled me for quite some time. Until I realized that the IE cleanup tool I was running during boot also removed all cookies (I now have that turned off). :-) /Steve
May 23, 2007 21:54
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.