Try our conversational search powered by Generative AI!

Remote Website webservice on IIS7 with Forms-authentication


Hi all,

I've been searching everywhere, but no answer found sofar.

We have two sites, Acceptance and Production. Both on IIS7 (Win2k8)
I want to set up mirroring, so I confirgured a remote site.
But on ping I get

"The requested web service was found but it not gives a correct response (check the user credentials is correct, that the WebService folder in the IIS not accepts anonymous access for the requested site and the remote site has the BasicAuthentication http module installed in its web.config), see the log file for the full error message."

Since the sites use MixedRoleProvider and is configured for Forms authentication, I guess this is where the poblem is.

I created an empty "webservices" directory in the root, and tried to set it to only allow Basic Authentication. I cannot disable Forms, it says its locked and read-only.

Is there a way to override this, either in IIS manager or within the web.config?

I'm really getting lost at the moment.

May 11, 2009 10:05

Hi Jeroen,

Few days back I got the same issue when I was trying to setup mirroring on vista-64 bit enviornment. I managed to get rid of this error by adding a Basic Authentication Module on the distination site.

Here are some steps that I followed:

  1. Open your IIS and select your destination site.
  2. Select Modules
  3. Add new module named "Basic Authentication" of type "EPiServer.Security.BasicAuthentication, EPiServer, Version=5.2.375.133, Culture=neutral, PublicKeyToken=8fe83dea738b45b7"

Now ping your distination, I hope this will lead you to a resolution.


EPiServer Support Team

May 12, 2009 8:59
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.