SaaS CMS has officially launched! Learn more now.

No redirection on login page



I've fetched a project from our TFS, we're using Episerver CMS 5 SP1 and IIS 7 for this project. After fixing the .dll references and solving other minor issues I've managed to get an error free solution. My problem is that now when I try to login on CMS to enter admin mode with my Windows admin credentials, the login is successful as there's no error, but there's never a redirection to the admin mode default page. The URL looks like this I've checked web.config and the paths seem to be correct.
This might be something pretty simple but i can't find the issue.
Any ideas or tips would be appreciated.



Jun 07, 2011 12:09

It seems that your windows account doesn't have a role that is allowed in the admin location in web.config. This is sometimes a problem with non-english versions of Windows where the administrators group is not called Administrators

Jun 07, 2011 12:17

Thanks for your reply! that was precisely the problem, 'cause my new computer has Windows 7 in swedish, so after adding Administratörer to the allowed roles in web.config it works, however when it redirects me to the Admin URL after logging in, then i get an "Invalid Link" error, like the URL can't be found.
Does it ring any bell?

Jun 07, 2011 13:13

Maybe your VPP configuration points the ui folder to c:\Program Files and your new PC is 64-bit so it should be changed to Program Files (x64). Or if it's in Swedish just Program instead of Program Files.

Jun 07, 2011 13:47

That was the first thing i checked and the physical paths appeared as correct when I copied/pasted them in windows explorer, even though they pointed to "Program Files (x86)" instead of "Program (x86)" which is the real name of the folder in my swedish window. I missed this detail which now I have corrected in web.config and made sure the paths are valid. However I still get the same error! Don't know where or what else to check..

Jun 07, 2011 14:06

I suggest you install an empty site of the same version using deployment center and compare the configs, for example the VPP paths.

Also, does the UIurl in siteSettings point to the same path as the vpp for the UI declares?

Jun 07, 2011 14:13

Thank you for your help. I did what you suggested and still no luck. Compared the web.config from an empty site with the one I'm using and even downloaded a fresh copy from the server and still nothing. The VPP point to valid locations and the siteSettings attributes are correct as well (siteURL, uiURL, utilURl).  I send the most interesting part of my web.config, in case I'm missing something which at this point is highly possible 'cause i've been scrolling up and down a thousand times already:

			<site description="Example Site" siteId="unknown">
				<siteSettings enableScheduler="true" stringCompressionThreshold="0" stringDelayedLoadThreshold="0" remoteWebServiceCulture="0" indexingDelayAfterPublish="00:00:20" uiDefaultPanelTab="0" indexingTextRegExp="[\p{N}\p{L}]{1}[\p{N}\p{L}-\._]*[\p{N}\p{L}]{1}" logServiceUrl="soap.tcp://localhost/TimeSpanAnalyzerView" uiImageTransparencyReplacement="White" globalErrorHandling="RemoteOnly" uiSafeHtmlTags="b,i,u,br" uiOptimizeTreeForSpeed="false" sgmlParserDecodeCharEntities="false" remoteCacheListenerShortNames="" httpCacheVaryByCustom="path" httpCacheVaryByParams="id,epslanguage" httpCacheExpiration="00:00:00" httpCacheability="Public" pageCacheSlidingExpiration="12:00:00" remotePageCacheSlidingExpiration="02:00:00" uiEditorCssPaths="" uiEditorColors="" uiEditorHeight="250" uiEditorWidth="500" uiEditorValueOptions="0" urlRewriteExtension="" urlRebaseKind="ToRootRelative" pageUseBrowserLanguagePreferences="false" uiShowGlobalizationUserInterface="false" subscriptionHandler="EPiServer.Personalization.SubscriptionMail,EPiServer" globalErrorMail="" mirroringRetries="5" mirroringRetryDelay="00:00:01" mirroringHtmlTextEncoding="Unicode" mirroringFileWriteRetryDelay="00:00:05" categoryId="1" pageRootId="1" pageStartId="4359" pageWastebasketId="2" pageOfficeStartId="0" uiMaxVersions="0" uiVersionMerging="true" pageValidateTemplate="false" uiKeepUserLoggedOn="true" siteUrl="" uiUrl="~/kultur/UI/" utilUrl="~/util/" siteDisplayName="Kulturradet" errorMailHandler="~/util/SendErrorReport.aspx" pageFolderVirtualPathProvider="Siteupload" uiTheme="" enableEvents="true" enableRemoteEvents="false" operationCompatibility="None"/>
		<virtualRoles replacePrincipal="true">
				<add name="Administrators" type="EPiServer.Security.WindowsAdministratorsRole, EPiServer"/>
                <add name="Administratörer" type="EPiServer.Security.WindowsAdministratorsRole, EPiServer"/>
				<add name="Everyone" type="EPiServer.Security.EveryoneRole, EPiServer"/>
				<add name="Authenticated" type="EPiServer.Security.AuthenticatedRole, EPiServer"/>
				<add name="Anonymous" type="EPiServer.Security.AnonymousRole, EPiServer"/>
				<add name="Creator" type="EPiServer.Security.CreatorRole, EPiServer"/>
		<virtualPath customFileSummary="~/FileSummary.config">
				<add showInFileManager="true" virtualName="Global Files" virtualPath="~/Global/" bypassAccessCheck="false" indexingServiceCatalog="Web" physicalPath="C:\EPiServer\VPP\Kulturrådet\Global" WriteAccess="Administrators" DeleteAccess="Administrators" name="SiteGlobalFiles" type="EPiServer.Web.Hosting.VirtualPathNativeProvider,EPiServer"/>
				<add showInFileManager="true" virtualName="upload" virtualPath="~/upload/" bypassAccessCheck="false" physicalPath="C:\EPiServer\VPP\Kulturrådet\upload" name="Siteupload" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer"/>
				<add showInFileManager="true" virtualName="Documents" virtualPath="~/Documents/" bypassAccessCheck="false" physicalPath="C:\EPiServer\VPP\Kulturrådet\Documents_1" maxVersions="7" customFileSummary="~/summary.config" name="SiteDocuments" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer"/>
				<add virtualPath="~/Util/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\Util" name="UtilFiles" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer"/>
				<add virtualPath="~/App_Themes/Default/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\App_Themes\Default" name="App_Themes_Default" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer"/>
				<add virtualPath="~/WebServices/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\WebServices" name="WebServiceFiles" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer"/>
				<add virtualPath="~/kultur/UI/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\5.2.375.133\application\UI" name="UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer"/>
		<urlRewrite defaultProvider="EPiServerFriendlyUrlRewriteProvider">
				<add name="EPiServerFriendlyUrlRewriteProvider" type="EPiServer.Web.FriendlyUrlRewriteProvider,EPiServer"/>
				<add description="EPiServer identity URL rewriter" name="EPiServerIdentityUrlRewriteProvider" type="EPiServer.Web.IdentityUrlRewriteProvider,EPiServer"/>
				<add description="EPiServer bypass URL rewriter" name="EPiServerNullUrlRewriteProvider" type="EPiServer.Web.NullUrlRewriteProvider,EPiServer"/>

<location path="kultur/UI">
            <httpRuntime maxRequestLength="1000000"/>
                    <add tagPrefix="EPiServerUI" namespace="EPiServer.UI.WebControls" assembly="EPiServer.UI"/>
                    <add tagPrefix="EPiServerScript" namespace="EPiServer.ClientScript.WebControls" assembly="EPiServer"/>
                    <add tagPrefix="EPiServerScript" namespace="EPiServer.UI.ClientScript.WebControls" assembly="EPiServer.UI"/>
            <globalization requestEncoding="utf-8" responseEncoding="utf-8"/>
                <allow roles="WebEditors, WebAdmins, Administrators, Administratörer"/>
                <deny users="*"/>
                <add name="webresources" path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader"/>
                <add name="PageHandlerFactory-Integrated" path="*.aspx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.PageHandlerFactory" modules="ManagedPipelineHandler" scriptProcessor="" resourceType="Unspecified" requireAccess="Script" allowPathInfo="false" preCondition="integratedMode" responseBufferLimit="4194304"/>
                <add name="SimpleHandlerFactory-Integrated" path="*.ashx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.SimpleHandlerFactory" modules="ManagedPipelineHandler" scriptProcessor="" resourceType="Unspecified" requireAccess="Script" allowPathInfo="false" preCondition="integratedMode" responseBufferLimit="4194304"/>
                <add name="WebServiceHandlerFactory-Integrated" path="*.asmx" verb="GET,HEAD,POST,DEBUG" type="System.Web.Services.Protocols.WebServiceHandlerFactory, System.Web.Services, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" modules="ManagedPipelineHandler" scriptProcessor="" resourceType="Unspecified" requireAccess="Script" allowPathInfo="false" preCondition="integratedMode" responseBufferLimit="4194304"/>
                <add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer"/>
    <location path="kultur/UI/admin">
                <allow roles="WebAdmins, Administrators, Administratörer"/>
                <deny users="*"/>

    Thanks again for you time!


Edited, Jun 07, 2011 15:47

Hi Kenia,

The virtual role "Administrators" should include the swedish administrator role "administratörer" as well. So you should not need to add it to the paths. Can you enable EPiServer logging to see if you get any errors?

Jun 07, 2011 17:17

Toni, if I didn't include the "administratörer" role in the virtual paths I would not be redirected from the login page even though the login succedeed, that's how i started this thread.
The problem is solved now, but unfortunately i still don't know what was wrong. I simply decided to start from scratch, so I created an empty project, copied the files from my project and change very little config options in the web.config, and now it's working perfectly. It's a relief, but it makes me a little frustrated that i never got to know where the problem was in my original project 'cause everything looked just fine.

Thank you guys for your time and help!


Jun 08, 2011 10:03

still Magnus, your first reply was the solution to my original problem, so fair enough to point it out on the site =)

Jun 08, 2011 10:05
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.