Untrusted domain error


Hello everyone!

I'm working on an EpiSever CMS 5 project, using asp.net 4.0, we use also ImageVault 3.4. It all worked fine until I suddently started getting the following error "The trust relationship between the primary domain and the trusted domain failed". First it was only when i tried to update a property of "URL to Image" type, the dialog would display the error,  but now i can't even load the tree in edit mode! Admin mode works fine and the site runs perfectly, it's in edit mode when i have the problem, specifically when loading the tree, the error message is displayed instead.

What I have tried:

- First I changed the membershipprovider i was using, since i logged in with my windows account, so i created a new account and added it to the WebAdmins group as suggested here http://world.episerver.com/FAQ/Items/The-trust-relationship-between-the-primary-domain-and-the-trusted-domain-failed/ I also tried changing the settings in aspnet.config although i didn't like this workaround, but still, it didn't work either. 

- After googling for a long while I found this other post http://world.episerver.com/Modules/Forum/Pages/thread.aspx?id=28505, so i set the right permissions not only to the VPP folder but also to the two folders (ImageDB and Orders) used by ImageVault, as it appears in the web.config file. Still, no luck.

So I'm clueless here, don't know what else to try or what could be causing MY problem, since none of the fixes that have worked for others seems to work for me. Help!!


Jul 01, 2011 9:44

Hi there, 

Does this happen on the server or on your development machine?

Jul 01, 2011 16:04

Hi, it's happening on my development machine which is in the domain

Jul 04, 2011 9:02

I've seen this issue before when using a laptop, removing the machine from the domain and re-adding it fixed the issue.

Jul 04, 2011 11:44

Hi Stephen!

Your tip fixed my problem, thank you so much!


Edited, Jul 04, 2011 13:35
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.