Try our conversational search powered by Generative AI!

No edit mode after moving site


So I switched to a new development environment and started setting up the site and the Visual Studio project. I created a new site using the Deployment Center and then hade the site and vpp folder as well as the SQL database replace with a copy from my old development environment. The site runs as expected but when I log in to my account and right click there is no menu and when I paste a link to a page in edit mode I get 404.

What's causing this? Any ideas?

Mar 14, 2013 6:35


What version are you runnig?

Have you checked the uiURL settings in episerver.config to see here your ui root is?

Mar 14, 2013 7:37

Sorry, I forgot to mention. I'm in 6.1.379.0

The root is set to /administration/CMS/ and when I visit it I get the 404 followed by:

Module IIS Web Core
Notification MapRequestHandler
Handler StaticFileHandler
Error Code 0x80070002
Requested URL http://localhost:80/sv/administration/cms
Physical Path C:\EPiServer\Sites\BmEPi\sv\administration\cms
Logon Method Anonymous
Logon User Anonymous
Mar 14, 2013 15:43

Have you tried removing the language segment "/sv" from the URL?

Mar 14, 2013 20:23

Hmm. When removing it I get our Danish site since it's the first in the alphabetical order but when adding the /administration/ I get a redirect to http://localhost/Util/login.aspx?administration. That's atleast something new, but it still gives me 404.

Mar 15, 2013 12:00

Hi. Did you solve this or is it still an issue?

Mar 19, 2013 17:00

No, I haven't had any time to look into into it. And to be honest, I don't know where to begin. Could I somehow have missed a component that needs to be added? The demo site I first installed and replaced it with worked fine though and the old development site as well, so I wouldn't see where it would had gotten lost.

Mar 19, 2013 17:08

Ok. Trying to give some input on how to problem solve this:

  • Check that you have EPiServer installed (which it seems). The UI will be fetched from the EPiServer folder in Program files.
  • Make sure that you have a valid uiURL in episerver.config, for instance "~/uiroot/CMS/".
  • You should have a virtual path settings that defined your ui. Locate the virtualPathProviders section in one of your config files and find a section that matches your cms root, for instance: <add name="UI" virtualPath="~/uiroot/CMS/" physicalPath="[some folder in program files]"
Mar 19, 2013 17:14

Yes, of course! Your last step nailed it. The old development environment ran Windows Server 2008 and referenced C:\Program Files\EPiSever\... while Windows 7 uses C:\Program Files (86x)\EPiServer. A quick replace of the virtual paths in episerver.config and it's all working as expected again. Thank you so much for pointing that out!

Perhaps I can take advantage of your knowledge once more while we're on the subject of moving to a new develop environment. When I open up the project in Visual Studio 2008 I get the following error message when I try to build. Any idea why?

"The "BuildWebProfile" task could not be loaded from the assembly WebProfileBuilder, Version=, Culture=neutral, PublicKeyToken=01d50f1f82943b0c. Could not load file or assembly 'WebProfileBuilder, Version=, Culture=neutral, PublicKeyToken=01d50f1f82943b0c' or one of its dependencies. The system cannot find the file specified. Confirm that the <UsingTask> declaration is correct, and that the assembly and all its dependencies are available. BmEPi"

Mar 21, 2013 6:23

Hmm, I've never heard of that and I don't think that it has to do with EPiServer. First search hit when I google it gives me a MSDN page that states "Web Profile Builder supports Visual Studio 2005 and 2008". Might it be that you are using Visual Studio 2012 on your new machine?

Mar 21, 2013 8:01

Sorry about my late replies. I wish I could concentrate harder on this problem but right now there's too much happening.

I'm not using 2012, I'm running 2008 and that's what I did in the last dev environment as well. I found the link below but the row he tells me to add is already in the project file. Any ideas? I re-installed the project but nothing.

Mar 25, 2013 15:48

Sorry, I missed the link at the top. A re-install of the WebProfileBuilder 1.3 did the trick. Thanks for all your help, Linus!

Mar 25, 2013 15:52
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.