SaaS CMS has officially launched! Learn more now.

EPiServer 7.1 fails to honor "en" language with Patch 2

Vote:
 

No matter what page i am on, the default language is "en" and looking at the page language, en is the page language.  When i navigate to the page like this http://joshua.local/test  it works!  if i go to http://joshua.local/en  it fails and i get a 404. 
Now the kicker.  If i go to episerverframework and look in sitehosts.  i have this <add name="*" language="en" /> and <add name="joshua.local" language="en"/>.  So all in all, i cannot navigate to any page with the en branch.  so joshua.local/en/about does not work but joshua.local/about does.  What am I missing.

#70425
Apr 19, 2013 2:33
Vote:
 

We have introduced something called StrictLanguageRouting in CMS. It works like:

Another change is that when a language mapping is defined in config, like if config contains a mapping like:

<add name="localhost" language="en" />

then a url like http://localhost/en/News/ will give a 404 since when there is a host mapping that defines a language then the language should not be present in url.

In short it works like if there is a language mapping in config then the url must not contain the language segment and the other way around that is if there is not a language mapping in config then the language url segment must be present.

There is a configuration setting "strictLanguageRouting" on configruation element siteSettings that can be set to false to get old more tolerant behaviour.

#70431
Apr 19, 2013 9:53
Vote:
 

Thanks Johan.  That seemed to do the trick. I failed to see this documented anywhere, did i miss this?

#70459
Apr 19, 2013 18:41
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.