SaaS CMS has officially launched! Learn more now.

Remote Events with multiple sites seemingly malfunctioning

Vote:
 

Hi,

I have an Episerver installation consisting of two sites.
The staging environment I work with has 1 Admin and 1 Front - Everything is working nicely here.
The production environment has 1 Admin and 2 Fronts -  Replication for neither site is working (unless the second endpoint is removed from admin).

Episerver cms version: 9.12.0.0.

To troubleshoot the production environment I went to the Staging environment and tried my first lead: the NetTcpPortSharing service.

I verified that the replication worked,
Disabled the Net.TcpPortSharing & Net.TcpListenerAdapter services,
Verified that the replication stopped working,
Started the NetTcpPortSharing & Net.TcpListenerAdapter services,

Desired behaviour: Remote events relection works again
Actual behaviour: Like in production, the replication for both sites doesn't work unless the second admin endpoint is removed.

Performing an iisreset on the front will make it recieve the changes published on the admin machine.

Staging Admin:


Where binding is:


  

Staging Front:


  
    
  
  
    
  

What's further confusing to me is the need for portSharing since we're not using the same port - but perhaps that's not its use?


Any help & tips on further troubleshooting this is warmly welcomed!
Let me know if anything is unclear or further information needed.

Thanks,
Fredrik

#182583
Edited, Sep 25, 2017 16:28
Vote:
 

(not editing original post because that removes the code snippets)

Actually, a simple cache invalidation by editing Web.config on a front will sync the changes, even when that endpoint is removed... The further I dig, the more clueless I get. 

netstat shows 2 established tcp connections on :5000 from admin:51149 and the other from admin:51159

#182590
Edited, Sep 25, 2017 17:01
Vote:
 

"Actually, a simple cache invalidation by editing Web.config on a front will sync the changes" and "Performing an iisreset on the front will make it recieve the changes published on the admin machine" makes me think you've misunderstood how this is supposed to work. The CMS is only sending remote events with cache invalidation messages, i.e. telling the cache to remove stuff on all subscribers. The events are not adding anything to the cache. Just want to make sure that this is not the issue.

#182591
Sep 25, 2017 18:09
Vote:
 

Ah right, thank you. I was under the impression that they added to the cache. Unfortunately knowing that doesn't solve my issue and I'm starting to doubt Epi is a part of the issue.


Probably significant is that I've found that only port :5000 works. Note that both :5000 and :5001 worked before restarting the net.tcp port sharing & listener adapter services though, which is a bit sketchy and likely the culprit or at least related to it.

So if I remove one endpoint the :5000 port works nicely, whichever site it is bound to (provided front is configured correspondingly). If two endpoints, none work. Running with 1 endpoint and changing the port from :5000 to anything else (and allowing that port through the firewall) doesn't work. 

I'll report back if I find an answer. If anyone has experienced similar things, I'll be delighted to hear your story.

#182619
Sep 26, 2017 13:25
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.