Try our conversational search powered by Generative AI!

Recycle Bin and Root Folder 404


I'm running an EPiServer CMS 5 SP3 site (5.1.422.267) with demo templates and I'm getting a 404 error when accessing the recycle bin/wastebasket or root folder as the DataFactory instance is returning the page link as /UI/edit/wastebasketpage.aspx rather than my customUI path.

I've checked my ID references and custom paths in the config and everything is as it should be.

Anyone come across this before and know the fix?


Oct 02, 2008 11:19

Did you check the url in the admin mode?
Look at the page types SysRoot and SysRecycleBin. Look at settings. -FileName
It has to be changed into /YOUR_UI_PATH/edit/.

Oct 02, 2008 12:32

Ah right, that was it. It wasn't updated during the install. Sorted.


Oct 03, 2008 15:21
Oct 09, 2008 10:08

Hi there

I am experiencing the similar kind of problem after upgrade a site from verion 5.1 to 5.2. Only the root node and recyclebin have this kind of problem, the admin site url looks fine to me.

Besides, can anyone explain a bit more about "Look at the page types SysRoot and SysRecycleBin. Look at settings. -FileName
It has to be changed into /YOUR_UI_PATH/edit/."....

Here is the error message I received.

Thanks & Regards

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /WBOPDCUI/edit/wastebasketpage.aspx

Version Information: Microsoft .NET Framework Version:2.0.50727.4200; ASP.NET Version:2.0.50727.4016

Jan 07, 2010 2:30

Problem solved.

The virtual path for admin section are defined in both web.config and database. table called "tblPageType"

In web.config the virtual path for admin is "private/ui/"

But in database table "tblpagetype", filename value for "name" sysroot and sysrecyclebin are different.

So, after changing them to the same value, the problem is fiex

Jan 07, 2010 4:40
Jan 07, 2010 15:03

I had the same problem with root folder and recycle bin.

I updated the field "filename" (table tblPageType) for SysRoot and SysRecycleBin from "/ui/..." to "/MYADMINPATH/...".

Problem solved

Edited, Jan 07, 2010 15:06

thanx. Silly install package :P 

May 17, 2010 10:53
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.