SaaS CMS has officially launched! Learn more now.

Error - ASPNET is not a valid user or group


I am trying to install a new site on our Windows 2003 server machine but every try gives me the error message "Error - ASPNET is not a valid user or group".

This seems very strange since this is a Windows 2003 machine which doesnt use the ASPNET account. Does anyone have any idea why this is occuring?

Nov 17, 2008 9:44

That sounds strange, 2003 sever does not have the aspnet user... Which version are you trying to install? And are you using the SDK installation, or the manager? 

Lars Øyvind 

Nov 20, 2008 7:20
I am trying to install the latest R2 release and I am doing this using the manager.
Nov 20, 2008 9:38
Just to make sure, EPiServer Manager 2.0.19.x or EPiServer Installation Manager?
Nov 20, 2008 11:19
And, you're doing this on a "clean" iis site? You haven't done any manualaspnet_isapi.dll configuration?
Nov 20, 2008 11:45

It is the EPiServer Installation manager from the latest R2 release.

 If you by Clean mean a new web site then no. I tried to install it as a virtual directory under an existing web site by providing an application name.

 I'm not sure exactly what you mean by manualaspnet_isapi.dll. I have checked the "ISAPI filters" tab on the website and that was empty and if I click the configuration button on the web site there is no such dll in the Application extensions list.

Dec 01, 2008 18:45

Did you resolve this? I have the same problem with a Windows 2003 Server, and I get this error after I have put all the credentials into the Installation Manager with R2 and start to install a web site.


Dec 17, 2008 13:39

This looks similar to the problem I had, see


Dec 17, 2008 14:36
Seems that the ASPNET account must exist on the server in order for the installation to complete, although the Network account is later used as worker process for the installed site. Don't really understand why, but problem solved. Thanks for the reply, Henrik.
Dec 22, 2008 0:35
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.