Try our conversational search powered by Generative AI!

File Manager search returns no results


I'm running an instance of version 5.1.422.122. I'm testing out the File Manager search function but I can't get any results.

I tried creating a txt file with some sample content in it, then added metadata to the Publisher, Author, etc fields. Searching for any of the text in the fields returned nothing. Then I tried searching for the exact file name - also nothing.

Does anyone know what might be wrong? Is there an indexer I need to turn on? If so, where is it? I can't find anything in the Editor or Admin manuals. 

Jul 15, 2008 11:57

When you install EPiServer 5, you also install an indexer. The problem usually is that when you create a news ite, the old site dissapear (depending on your enviroment).

Check this file to see if your site is there (and have the right settings): C:\Program Files\EPiServer.IndexingService5\EPiServer.IndexingService.exe.config

There is also a Logs-folder where you can see errors when indexing.

If the indexing is working correctly you will get a index-folder in every virtual file provider you run the indexer in.

Jul 15, 2008 13:48

Hi Erik,

Thanks for the reply. I personally don't have access to the server where the site is installed, I'll have to ask the people upstairs for that... Smile

I'll pass on your ideas and await a response...
Jul 15, 2008 13:56

Also check the indexingServiceCatalog attribute is set against your provider in the web config:


      virtualName="Page Files"
      type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer" />

Jul 21, 2008 15:31

Hi Rachel, thanks for your suggestion.

We ended up just opening EPiServer CMS Manager on the host server and clicking on the Capabilities tab, then under Indexing clicking Enable for each site. Seems to have worked, only now I have another problem... perhaps you might also know the answer?

The thread is here.

Jul 31, 2008 15:22
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.