Try our conversational search powered by Generative AI!

EPiServer.XmlRpc.dll is deleted from the bin directory


I am currently testing an almost unmodified installation of CMS5 SP2 including the demo template package. I have added an ASPX and a couple of ASCX files, and I am testing a graph component (WebChart from ComponentArt), so I have to recompile the project.

The problem that has now occured three times in two days is that the file EPiServer.XmlRpc.dll suddenly goes missing from the bin directory, resulting in the site not running at all because it affects the blog functionality. This is worrying, is it a known bug?

The exception error message reads as follows:

EPiServer.PlugIn.PlugInException: Failed to load some types from "EPiServer.Blog": Could not load file or assembly 'EPiServer.XmlRpc, Version=, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' or one of its dependencies. The system cannot find the file specified.

Aug 05, 2008 15:34
I'm not 100% sure, but if you do a rebuild of a web project in Visual Studio the compiler will remove any dll's that are not listed in the assemblyBinding section in web.config or referenced by the project.
Aug 06, 2008 13:19

That could be it, it is certainly missing from the assemblyBinding section in web.config. I noticed that it is only removed if I run Rebuild Solution in Visual Studio, but not if I run Build Solution (and I don't really need to use rebuild).

I guess the assemblyBinding-update needs to be included in the Web.Config.xmlupdate file for the demo template package.

Aug 06, 2008 14:13

Hi I have the same problem but the dll:s that are being removed when I issue the rebuild command are included in the assemblyBinding.

The files that are being removed are:


If I replace the files by copying them into the bin folder, they aren't removed by the first rebuild command, but when rebuilding it once more, the files are deleted.

And they are listed in the assemblyBinding in the web.config. (using Visual Studio 2008 on a Vista machine)

Oct 20, 2008 12:50
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.