Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Edit of page not possible


We moved both the live and test environment from physical servers into a VMWare environment and everything works with the live environment. But on the the test environment edit on the page is not possible. In edit mode the only visible tab is View, and if I from the contextmenu in the sitetree chooses edit no page is loaded. What has happened?

My first thought was that it has something to do with the database on the test server since this problem affect both my local test environment and the test environment on the server, and both databases are on the test server. But I can't figure out what may affect this.

Image of the error

Mar 20, 2009 11:29
Are you sure you have all .dll-files copied to this environment? Or maybe there are som episerver-files missing in the GAC. Not sure this is the problem, but worth a look.
Mar 20, 2009 15:03

The thing is when we move to the VMWare environment we take an exact copy of the server so nothing should be different. The whole testsite runs properly in both view and adminmode.

As I said the move worked without problem on the live server and the difference there was that the database is on another server. We have moved the database server itself into VMWare aswell and all works fine. But im not sure it has anything to do with this whatsoever. It's all just so weird.

Mar 20, 2009 15:24
Resolved it. It was a reference to an EPiServerMail dll that somehow caused this problem. Removed it and all worked. Weird
Mar 26, 2009 8:53
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.