Try our conversational search powered by Generative AI!

EPiServer 4.62B Edit Mode 404


In Edit mode my web does not show tabs looking like tabs. They just look like text, so I am assuming that there are some missing images. Using Nikhil Kothar's Web Development Helper I find that the web is trying to load some gifs and also the script using veird urls which result in 404 errors, for instance:

So it looks like it doesn't understand that the variable $RootDir$ should be translated into something else.

Any ideas on how to fix this problem?

Svein Terje Gaup

Mar 04, 2010 14:50

Are you experiencing this locally or on a server? Which IIS version are you using?

Mar 04, 2010 15:00

Hi and thank you for helping me, I am experiencing it on both. I created a dummy site using the EPiServer Manager, and that site is OK. The sites with problems have been upgraded from 4.51. It seems like the $RootDir$ variable is replaced on the fly by EPiServer by some other value, I am thinking maybe it's mapped to Global.EPConfig.RootDir, which is maybe configured using the EPsRootDir setting in Web.config. But this setting is the same on all webs, with the value "/".

Mar 04, 2010 16:08

IIS version is the one that came with Windows XP on my developer machine, and version 6 (on Windows Server 2003) on the server.


Mar 04, 2010 16:39

I would install a clean site on EPiServer 4.62, make sure it works, and then replace the util, edit, admin etc folders on your site with the ones from the working site, just to make sure they're identical. See if that helps.


Mar 04, 2010 16:45

Correction: my developer pc which is running WinXP SP2+ is ok. Just tried to copy the contents of the util-folder again to the server (running IIS6) from a working web, but still does not work.

Mar 05, 2010 9:22

Hmm okay, do you see any major differences if you do a compare between the web.configs?

Mar 05, 2010 10:19

Update: I had a site that was installed using the EPiServer Manager, which were working fine, so what I did was change the Home Directory path of that site to point to my other web site: It's working! Finds all style etc. So what is the EpiServer Manager doing when it sets up a new web site in IIS? I am trying to compare settings on the two web sites to see if there are any differences that could be the cause of the problem.

Mar 05, 2010 11:37

In IIS it only sets the 404 custom error to the path /util/notfound.aspx. Could be one of two things: the web.config file or missing files in /util/, /edit/, or /admin folders.

Mar 05, 2010 11:45

Ok, now I have discovered something else. When I configure a Host Header in IIS on the site that was working fine, the problem is back. EPiServer does not like host headers :D Are there any settings in web.config that could be adjusted to fix this?

Mar 05, 2010 12:07

I am beginning to think that this may be a bug in EPiServer.

Perhaps they forgot to test using host headers... Sounds a bit unlikely maybe? Should I report a bug?

Mar 05, 2010 14:17
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.