Try our conversational search powered by Generative AI!

TinyMCE not working properly - Newbie



I have upgraded an EPiServer solution from 5 SP2 to 6 R2.

After a lot of hassle tweeking the web.config and  episerver.config the site (intranett) is now running - well almost.

The TinyMCE has issues:

1. The TinyMCE and TinyMCE dialogs have text/captions like this {#advimage_dlg.src}

2. The settings for the TinyMCE toolbars in admin mode does not show the toolbars or any buttons.

Clearly some references are missing, but I have yet not been able to figure out where/what this is.

It would be great if someone could point me in the right direction....



Nov 28, 2011 9:59
  1. Sounds like you are missing some files in /lang
  2. Has /Util been linked in correctly? Is /Util/Editor/tinymce/themes/advanced/img/icons.gif returning an image for instance?
Nov 28, 2011 16:27

Thanks for your advices

I have found the problem with the missing configuration of the TinyMCE in Admin mode:

When Epi was first installed the virtualPath was changed from ~/EPiServer/CMS/ to ~/cms/ to reduce the amount of text for the URL to access the edit and admin modes. Being new to this I'm not quite clear on how this works, but it seems that I lost one level in the "not working" configuration.... 

I have now reverted to the original settings and the config part of the TinyMCE works.

The lang files are still not picked up though....


Nov 29, 2011 8:50

Hi Johan

The virtualPath for Util looks like this:

<add name="UtilFiles" virtualPath="~/Util/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\application\util" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />

And it (Util) is used in the "location path" tag and in the "site settings" tag.

There are no other references to Util in web.config or episerver.config. I have a demo site where the TinyMCE is translated correctly, and I have searched the config files for this site for differances that might be related to this, but no luck. I have also copied the lang folder of the demo site to my site without any luck.

There is obiously something I'm missing/not understanding.


Nov 29, 2011 11:28

First step is to check if C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\application\util exists in your file system.

Also, which IIS are you running? If it's IIS7 make sure you have handlers in system.webServer in your Util-location-block in web.config. If it's Visual Studio Web Dev Server (Cassini) or IIS6 there should be httpHandlers in system.web instead.

Nov 29, 2011 13:10

Also try looking with Firebug or other dev tool to see which resource requests fails when you open a page for editing.

Nov 29, 2011 13:12

The Util path is valid.

I'm running IIS 7.5 and here is my system.webserver and  Util location block.  

<clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="1.00:00:00">
<add extension=".gif" policy="DontCache" kernelCachePolicy="CacheUntilChange" duration="0.00:01:00" location="Any" />
<add extension=".png" policy="DontCache" kernelCachePolicy="CacheUntilChange" duration="0.00:01:00" location="Any" />
<add extension=".js" policy="DontCache" kernelCachePolicy="CacheUntilChange" duration="0.00:01:00" location="Any" />
<add extension=".css" policy="DontCache" kernelCachePolicy="CacheUntilChange" duration="0.00:01:00" location="Any" />
<add extension=".jpg" policy="DontCache" kernelCachePolicy="CacheUntilChange" duration="0.00:01:00" location="Any" />
<add extension=".jpeg" policy="DontCache" kernelCachePolicy="CacheUntilChange" duration="0.00:01:00" location="Any" />

<location path="util">
<pages enableEventValidation="true">
<add tagPrefix="EPiServerUI" namespace="EPiServer.UI.WebControls" assembly="EPiServer.UI" />
<add tagPrefix="EPiServerScript" namespace="EPiServer.ClientScript.WebControls" assembly="EPiServer" />
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />
<clear />
<add name="webresources" path="WebResource.axd" verb="GET" type="System.Web.Handlers.AssemblyResourceLoader" />
<add name="PageHandlerFactory-Integrated" path="*.aspx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.PageHandlerFactory" modules="ManagedPipelineHandler" scriptProcessor="" resourceType="Unspecified" requireAccess="Script" allowPathInfo="false" preCondition="integratedMode" responseBufferLimit="4194304" />
<add name="SimpleHandlerFactory-Integrated" path="*.ashx" verb="GET,HEAD,POST,DEBUG" type="System.Web.UI.SimpleHandlerFactory" modules="ManagedPipelineHandler" scriptProcessor="" resourceType="Unspecified" requireAccess="Script" allowPathInfo="false" preCondition="integratedMode" responseBufferLimit="4194304" />
<add name="WebServiceHandlerFactory-Integrated" path="*.asmx" verb="GET,HEAD,POST,DEBUG" type="System.Web.Services.Protocols.WebServiceHandlerFactory, System.Web.Services, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" modules="ManagedPipelineHandler" scriptProcessor="" resourceType="Unspecified" requireAccess="Script" allowPathInfo="false" preCondition="integratedMode" responseBufferLimit="4194304" />
<add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" />
<location path="App_Themes/Default">
<allow users="*" />
<add name="wildcard" path="*" verb="*" type="EPiServer.Web.StaticFileHandler, EPiServer" />

Nov 29, 2011 13:20

The problem above was resolved by adding the missing cache settings:

<add name="ClientResourceCache" enabled="true" duration="3600" varyByParam="*" varyByContentEncoding="gzip;deflate"/>

Jul 06, 2012 8:22
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.