SaaS CMS has officially launched! Learn more now.

CMS sub menu (Edit, Admin, etc.) does not exist



we're experiencing a weird problem in a production environment. The submenu under CMS does not exist (Edit, Admin, etc.). It's not even rendered from the server. The CMO submenu renders just fine.

It works fine in all other environments, from dev to staging.

It does not seem to be a problem with access, since a user with edit/admin access can still go to the respective area by going straight to the correct URL. The QuickNavigator links also works.

Versions are Core 7.19.1 and UI 7.18.1

Anyone recognizes this problem and can give us any pointers?

Nov 21, 2016 9:57

Problem solved. We had a custom menu provider that probably due to a copy/paste error had a MenuItem with the path "global/cms". I guess whichever module got loaded first owned the sub menu and therefore it worked on some environments but not others.

Nov 21, 2016 11:37
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.