Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Upgrade to CMS version 10.3 gives me error while editing block



Recently I have upgraded my application from CMS 9.12 to 10.3 hosted on Azure cloud. When I am trying to click on edit button for any block it is giving me below console error:

Failed to load resource: the server responded with a status of 404 (File not found)
dojo.js:15 Error: scriptError
at _f (dojo.js:15)
at HTMLScriptElement. (dojo.js:15)
(anonymous) @ dojo.js:15
widgets.js:2 Error: scriptError
at _f (dojo.js:15)
at HTMLScriptElement. (dojo.js:15)

For some of the pages, it gives error:

Preview Unavailable

Failed to load the preview within the given time constraints.

Could anyone help me out from this.

Thanks in advance.


Sanket Mahimkar

Dec 29, 2016 10:16

It also gives follwoing error:

dojo.js:15 GET https://localhost:44302/EPiServer/Shell/ 404 (File not found)


Dec 29, 2016 10:57

I have changed my ClientEditingClass from 

ClientEditingClass = "epi.cms.contentediting.editors.SelectionEditor";


ClientEditingClass = "epi/cms/contentediting/editors/SelectionEditor";

//Sanket Mahimkar

Dec 29, 2016 11:11

Try changing to "epi-cms/contentediting/editors/SelectionEditor".


Dec 29, 2016 11:28

I did that just before your email. Thanks for the reply though and it worked!!

Happy new year!!


Sanket Mahimkar

Dec 29, 2016 11:35
<p>This worked for me<br />"epi-cms/contentediting/editors/SelectionEditor"</p>
Jan 03, 2017 16:07
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.