Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

"Sequence contains more than one element" on executing migration steps

Vote:
 

Hi, 

When performing an epi upgrade, CMS from v11.15.0 to 11.15.1 and commerce from v13.18.1 to 13.20.0, after logging in to execute the migration steps (the migration steps page is not displayed), the following error occurs (at the /EPiServer/Commerce/Migrate url): 

The error looks related to Dynamic Data Store component so I've looked at the tblBigTableIdentity and I found some entries having the same GUID.

Is this the cause of the issue? If yes, what could cause it?

Thank you.

#225555
Jul 20, 2020 14:05
Vote:
 

Issue is definitely related to that entry. I would recommend to contact support and log a bug. They can better do troubleshooting on it.

Have you tried removing that duplicate entry?

Remember to take backup of database first :)

#225557
Jul 20, 2020 18:45
Vote:
 

It is important to note that MigrationSteps are stored in a different Store. The one you posted is for Shell components and should not be touched.

I suggest to contact developer support services, but if you want to poke around, for fun or for educational purposes, then look into VW_EPiServer.Commerce.Internal.Migration.MigrationStepInfo (view, not table) to see if there are duplicated rows. As Praful said always backup your database first if you want to update it directly (which is not supported by Episerver) 

#225586
Jul 21, 2020 7:29
Vote:
 

Thank you for your suggestions. I contacted develop support services.

I tried to remove the duplicate entries but same result.

Also, I took a look at VW_EPiServer.Commerce.Internal.Migration.MigrationStepInfo view and there were no duplicated rows. 

However, I did manage to start the web app by starting the commerce manager app first (I think it managed to execute all the migrations steps with success) and then started the web app again. 

#225692
Jul 23, 2020 14:23
Vote:
 

That is very strange, because CM does not run migration steps. In fact it is required to run the cms site first so the steps can complete. 

#225693
Jul 23, 2020 14:36
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.