SaaS CMS has officially launched! Learn more now.

Commerce SQL migrations is broken

Vote:
 

I'm upgrading a CMS + Commerce site from CMS 11 and Commerce 13 to CMS 12 and Commerce 14, but running into serious problems regarding SQL migrations. 

I started digging into it and compared the SQL scripts of Episerver.Commerce.Core 13.32.5 and Episerver.Commerce.Core 14.5.0, and found out that the SQL scripts for schema versions 10.0.31 and 10.0.32 are completely different! So, the "same" files in the two Nuget-packages are different - they should be 100% equal. I've only checked 10.0.31 and 10.0.32, so I can't speak for earlier versions.

#288764
Oct 06, 2022 14:51
Vote:
 

You are absolutely correct. there seems to be an oversight, as we continue to provide bug fixes on 13.x, newer 13.x versions might contain db changes. as we should have changed the name of files in 14.x to 11.x.x.sql instead of keeping it 10.x.xsql.

I will file a bug to Commerce team 

#288804
Oct 07, 2022 6:48
Vote:
 

THe bug is COM-16255 and it's being worked on with high priority

#288940
Oct 10, 2022 9:29
Andreas J - Oct 10, 2022 12:24
Will you also include https://world.optimizely.com/forum/developer-forum/Problems-and-bugs/Thread-Container/2022/10/asp-net-identity-migration-not-working-if-previously-used-with-commerce-db/? For some reason it has not gotten any response, even though it's serious as well.
antonahlstrom - Nov 07, 2022 9:53
Hi, do you have any updates on this issue? Been nearly a month since your latest reply.

Thanks,
Anton
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.