SaaS CMS has officially launched! Learn more now.

'Publish Changes' button doesnt show up after editing propertines in Settings tab

Vote:
 

After an upgrade to CMS 12, this only happens for properties that are edited under the Settings tab.   There are no errors showing up in console after editing any properties either. 


#323248
Jun 07, 2024 11:23
Vote:
 

Have you tried to check response of Content Version - POST api once changing property value?

If not, try to check this one and let's see what happens

#323253
Jun 07, 2024 13:50
Vote:
 

Hi Bihn, thanks for your reply and suggestion. I tried this and everything there looks correct there from what I can tell. 

I did notice something that might be able to help troublshoot.


We recently upgraded from Geta.SEO.Sitemaps to Geta.Optimizely.Sitemaps and I see this warning in the logs. The page Im having this issue with is using the PropertySEOSitemaps property from the newer .net core library so it should'nt be trying to create the PropertyData instance from  type Geta.SEO.Sitemap.... I think this might be related to the issue.   


When I created a new page there were no issues. Its only with the existing page with the older data and property mappings.

warn: EPiServer.Construction.Internal.PropertyDataFactory[0]
      Unable to create a PropertyData instance of Type: 'Geta.SEO.Sitemaps.SpecializedProperties.PropertySEOSitemaps' Assembly: 'Geta.SEO.Sitemaps'. Will fallback using the data type instead.
#323256
Edited, Jun 07, 2024 16:33
Vote:
 

I updated this assembly in the db record but the issue still persists

#323372
Jun 10, 2024 16:51
Vote:
 

Actually, Geta changes assembly name then namespace as well for new Optimizely Cms 12 version to Geta.Optimizely.Sitemaps. I think it is reason cannot create instance with Reflection for property data from your db with old assembly name. I think you need to do upgrade your db for this one as well

#323412
Jun 11, 2024 8:27
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.