SaaS CMS has officially launched! Learn more now.

Google reCAPTCHA is not working in Episerver Form



 I am working in a project where we are using Episerver.Forms with version

 I have to implement google reCAPTCHA in one of the form. For that I referred .

 I have created the specified files and tried but it won't work. So I tried other way by installing the EpiServer.Forms.Samples nuget package. But here also I am facing some issues.

 Can we implement google reCAPTCHA by using the EpiServer.Forms.Samples nuget package only? Or do we need to add any extra code other than this nuget installation?

Aug 07, 2018 10:45

Hi Anju

Did you get help in this?

I read you have already the recaptcha element in project from the samples package you installed. 

To implement this, so recaptcha element is visible in your form, you need to add secret and site keys from you google account. You can register site and get keys here (its free as of now)

This should be added individually on each recaptcha element you use. 

This can later be easily programmed to get from code so you skip filling those keys. Follow this to fix

You dont need to do anything else and this should work now.

good luck

Jan 03, 2019 9:52
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.