Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Shared Form Fields - Not mapping with Salesfore Connector properties

Vote:
 

Hi,

I'm trying to map form fields with Salesforce Case objects properties, when we create new form field its showing the dropdown and allowing user to map salesforce property with form field.  

At the same time when we try to map shared Optimizely form fields and Salesforce properties, but its not enabling the dropdown (external system field mapping) to select the Salesforce property.

 

Any suggestions or thoughts to fix this issue?  

Thanks,

Hari

#322095
May 15, 2024 18:26
Vote:
 

Just making sure -- on the form container itself, have you set the Mapping to the Salesforce connector? Once the form itself is mapped, then you should have the new option for mapping the individual form fields to Salesforce properties.

#322097
May 15, 2024 18:48
Harinarayanan - May 16, 2024 11:27
Yes Daniel, the Datasource at the form level is correct.
Daniel Isaacs - May 16, 2024 14:45
Ah, sorry, I missed the core of the question, about using shared form fields.

Based on Vincent's comments below, it might be worth emailing support to troubleshoot/submit a possible bug.
Vote:
 

Hi

According to the following blog post, it seems you're running into the known issue for shared form element.

Gotcha’s with reusing Episerver Forms ElementBlocks (optimizely.com)

#322142
Edited, May 16, 2024 5:53
Harinarayanan - May 16, 2024 11:28
Yes Vincent, Looks like its exactly same issue. but I don't see any solution on that blog.
Vincent - May 16, 2024 12:24
Have you tried to build form with this shared element and then submit the form to see if data is captured in SF? From memory, it should work.
Harinarayanan - May 16, 2024 12:49
Yes, I tried, still no luck Vincent.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.