Try our conversational search powered by Generative AI!

Tracking scripts not added to the page.



I have added the webcontrols to my masterpage (in head and before end body):

I'm inheriting from TemplatePage and have also added Track() to my query. What am I missing?

var service = ServiceLocator.Current.GetInstance();
var a = service.GetRequiredResources("Header");
var b = service.GetRequiredResources("Footer");

Gives me nothing...

Nov 20, 2014 2:59

The tracking tags are added to all hits' URL. It's just the scripts that are missing.

Nov 20, 2014 3:01

Hi Johan!

I think you are testing in Internet Explorer? IE has a function called "Do Not Track" that is as default set to true. If you want to test if that's the problem, then in IE click on the cog wheel in your upper right corner, then click on "Safety" -> "Turn off Do Not Track requests". 

Dec 04, 2014 15:08

Yep I did and your are correct! I was really scratching my head here. This should be mentioned in the documentation, or maybe it already is? Thanks!

Dec 04, 2014 18:06

I'm trying to mark your comment as answer. But nothing happens :( Thanks anyway.

Dec 04, 2014 18:08
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.