Try our conversational search powered by Generative AI!

Removing Find but keeping packages


We need to stop using Find for business reasons and I am having a hard time figuring out how to remove it/disable it without ripping out the packages (didnt want to do that incase we do need to easily turn it back on).
I have commented out all refrences to it in the web.config and removed our own custom initialization module but its still trying to run framework initialization modules and errors out since it cannot find the service url.

Errors I am getting:

[ConfigurationErrorsException: The serviceUrl cannot be empty]
   EPiServer.Find.Client.CreateFromConfig(Boolean bypassLicenseRestriction) +497
   EPiServer.Find.Framework.SearchClient..cctor() +20

[TypeInitializationException: The type initializer for 'EPiServer.Find.Framework.SearchClient' threw an exception.]
   EPiServer.Find.Cms.Module.IndexingModule.InitializeClient() +453
   EPiServer.Find.Cms.Module.IndexingModule.Initialize(InitializationEngine context) +41
   EPiServer.Framework.Initialization.Internal.ModuleNode.Execute(Action a, String key) +58
   EPiServer.Framework.Initialization.Internal.ModuleNode.Initialize(InitializationEngine context) +123
   EPiServer.Framework.Initialization.InitializationEngine.InitializeModules() +248

This is on CMS 11 and Commerce 12.

What else do I need to do to get it completly disabled? Thanks.

Jul 31, 2019 16:30

There is no way to "disable" Find. Find will always look for the settings to communicate with the server. Installing Find via nuget packages should be easy enough so I don't think that would be any trouble if you want to add it back on.

Jul 31, 2019 17:08

Okay thanks. Just wanted to make sure there was not any easy way to disable it before going through and removing packages and removing our code that references it.

Jul 31, 2019 17:10
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.