Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

/IndexingService/IndexingService.svc not mapped?


We seem to never get /IndexingService/IndexingService.svc up and running. Svc is working, and we can copy the files manually into the project, but /IndexingService/IndexingService.svc always results in a 404.

Where/how is /IndexingService/ mapped up when you install CMS 7?

Feb 11, 2013 14:14

You can find the reference of it inside web.config. There is a path to the indexingservice. You could also try to reinstall .net 4 with the regiis -i command for your specific versio. That might cause the problem as well.

Feb 12, 2013 13:03

IndexingService is part of EPiServer, so I don't see why we should use regiis to get it to work.

So far we ended up including it and the dll's manually into the project. That seems to work just fine.

Feb 13, 2013 14:45

the indexingservice is based on WCF that is a part of .net. If your IIS has been configured the wrong way you might need to re register the .net into IIS to make it work ok. Not sure why this is happening but i have stumbled across this issue a couple of times when I get a new server that should be ready for EPiServer with .net installed. This command is easy to run an will not make a mess just re register .net into iis.

Here is a thread on stackoverflow with more information:

Feb 13, 2013 15:00

But if WCF was't registered correctly, then copying IndexingService.svc directly into the project should't have worked.

Feb 13, 2013 15:09

But can you browse to the indexingservice.svc file? If not you need to enable that first to get the indexingservice to work. You should end up with a page that say:


Endpoint not found.

If you get a 404 something is not working on the server therfore you might try the regiis command to start with.

Feb 13, 2013 15:15

I copied IndexingService.svc to ~/IndexingService.svc. This works just fine and gives endpoint not found, etc.

But ~/IndexingService/IndexingService.svc still gives a 404.

Feb 13, 2013 15:17

that sounds strange. maybe a stupid question but you have a folder and a file in that directory? Have you tried to installed a demo website on the machine?


Maybe this is something you can check:

Feb 15, 2013 16:01

Try adding this to the system.servicemodel.  I always get Endpoint not found but the service is actually working just fine.  One thing we have to add to the sites especially local ones is "<serviceHostingEnvironment multipleSiteBindingsEnabled="true" />" to the system.servicemodel node.  But you should see it working once  you restart the app pool after adding this.

Feb 16, 2013 2:36

hey Tore, Is your issue resolved?

Feb 24, 2013 6:08
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.