Try our conversational search powered by Generative AI!

XHtmlString properties breaks forms edit mode


I have a brand new project:

  • Created with File->New Project->EPiServer MVC Site
  • Patch 2 applied
  • Upgraded to 7.1

I've added a couple of page types and templates and everything works fine.

However, whenever I add an XHtmlString property to a page type I'm no longer able to access forms mode for pages of that type. That is, if the page has a template nothing happens when I click the forms button except it changning to to show a loading indicator. If the page doesn't have a template I see the "Preview is not available for this page" message but forms mode isn't opened.

I can't see any errors reported in Firebug's console. No errors or warnings are written to the log4net log.

I've cleared all ASP.NET temporary files folders as well as browser cache. Occurs in all browsers I've tested (FF and Chrome).

If there was a way to downgrade to 7.0 I'd happily try that, but... :) 

Apr 14, 2013 14:51

I should also add that I've tried making the properties not available in edit mode without any different results. I've also tried different names for the properties without any change.

Apr 14, 2013 14:53


As usual, directly after asking for help I found the problem.

It turned out that I had uiEditorCssPaths pointing to a file that didn't exist.

Some sort of error message would have saved me an hour or two of frustration :)

Apr 14, 2013 14:59

Hi Joel,

Had you changed that path? I'm just wondering why that would break on a new install?


Apr 14, 2013 16:22


Yeah, I had. Just couldn't imagine that that could have such drastic consequences which is why I didn't mention it. Lesson learned :)

Apr 14, 2013 16:30
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.