SaaS CMS has officially launched! Learn more now.

Upgrade to R2 SP2 - Problem with language when creating pages programmatically

Vote:
 

Hi, I have upgraded from R2 SP1 to R2 SP2. I have an importjob where I can create new Episerverpages. I use the /officeIntegration/Preview.aspx file for preview of the imported page. After the upgrade there are no "Publish" and "Save and Publish" buttons in preview.aspx anymore.

When I look at the page in editmode I got the message "The page is not available for the active language". There is no globalization. and Norwegian is the only activ language, The language at the page is also Norwegian.

Have anyone seen this before, and can tell me what to do?

#39352
May 12, 2010 12:17
Vote:
 

Try enabling Globalization, then go to edit mode -> Language Settings -> Under available languages, make sure "norsk" is checked, then go back to admin mode and disable globalization again.

#39354
May 12, 2010 17:40
Vote:
 

Is this the same issue ? If so you can request a hotfix from Support.

#39398
Edited, May 14, 2010 8:47
Vote:
 

This issue has been solved in a hotfix.

Please do following steps to apply this hotfix:

http://support.ep.se/upload/Hotfixes/EPiServer%20CMS%205.2.375.237%20[26280].zip

1.     Unzip the sent file.

2.     Place the assembly into GAC

3.     Allow the application is recompile

4.     Try to do an iisreset also clear up the browsers cache.

Be sure to make backup in case you encounter problems installing this.

#39483
May 18, 2010 10:32
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.