Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Uninstall Episerver Mail from episerver

Vote:
 

does any one know how do uninstall the EPIserver mail Plugin from episerver 5 R2

1) deleted all the dlls

2) removed reference in config.

3) disable plugin in admin mode under Plugin Manager

The tab is on both edit mode edit Tree and on each Page as tab (example like we have edit , workflow tab)

Edit tree works fine but the page crashes give object null exception.

anyone know how do I unistall the EPiMail completely.

Regards

Abhishek

#80756
Jan 31, 2014 10:44
Vote:
 

Could it be that you removed some plugin added by the dlls and now it crashes sincethe AssemblyName and TypeName in the db no longer matches any implementation? That would perhaps not result in a null pointer though. A guess is that it is the remaining tab that is the culprit in some way.

Try having a look at what EPiServer does in its EPiMail installation powershell scripts. In the installation directory (or extract the msi file with Microsoft Orca or Lessmsi) I believe I've seen an SQL-file for Mail adding tables and what-not. You will also find a directory with configuration changes that the mail installation does there. This won't give you what the EPiMail dlls might add to the database in regards to GuiPlugIns etc, but it's a start.

Another but rather cumbersome way would be to set up a site without Mail, back up the filestructure, and then install Mail and initialize the site while at the same time running a trace on the database (SQL Server Profiler) to see what is done in there; and then doing a simple folder/file diff on the files.

Maybe not a simple answer but it's a way forward.

#80799
Edited, Feb 03, 2014 8:06
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.