Try our conversational search powered by Generative AI!

Lucence FTS in R2 doesn't create any index files...



Saw that the FTS from relate was released this friday so I decided to give it a try. I followed the instruktions in this blog post ( but no index files are created. I can see that it pushes pages and files to the "tblBigTable" and http://mysite/IndexingService/IndexingService.svc is responding with "Endpoint not found". I'm I missing something here? Any ideas whould be appriciated... I'm running the site on Windows 7 x86 and .Net 4,0.

May 29, 2011 21:57

Got this to work now... Googled a lot but nothing I found worked for me. I finally ended up adding handler mappings for .svc manually for my site. This can be done in IIS Manager. I copied the mappings from my "Default Web Site".

May 30, 2011 20:47


I have a similar problem.

The index is populated but no matter what I try searching for no results are returned. I'm using the FTS Facade by Paul Smith to populate the index and also to retrieve search results.

I hava also tried to retrieve the results directly from the FTS client like so:

            FuzzyQuery query = new FuzzyQuery(searchTerm, Field.Default, (float)0.5);
return EPiServer.Search.SearchHandler.Instance.GetSearchResults(query, 0, 10);
But nothing seems to work.
Any input appreciated! :)


Jul 21, 2011 1:22

I found the problem. The page parameter is not zero based like the offset. Doh! It needs to be 1 or greater otherwise the service will be called with -10 for the offset which throws a 500 error.

Jul 27, 2011 1:46
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.