Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

EpiServer 6 TinyMCE Editor issue

Vote:
 

We are facing an issue with respect to EpiServer 6 Tiny MCE editor

I have added three styles “Heading 1”, “Heading 2”, “Heading 3” in the custom Styles dropdown. In the editor content I have added a table using the editor options and trying to apply these custom styles to texts in some of the cells. I select the text in a cell, then select a style in the Styles drop down, it adds a class attribute to the parent tag of the text or sometime it creats a span tag and applies to it.  Surprisingly for some of the cells it applies properly and for some it doesn't. It looks like, if the class is applied to <p> tag, or <span> it perfectly renders in the view mode and saves properly. But if it applied to <td> tag, it doesn’t, it nither displays in the view mode, nor saves when I save and publish. 

I searched for a solution in the web, it looks like there is a bug in TinyMCE, there were few suggestions but I could not apply that. 

Do you have any idea how to fix this issue? Because it is not consistently applying, for some cells it applies to span and for some it applies to p and for some it applies to td.
Do you have any idea is this fixed with the new tinymce release? If so how to upgrate the cms editor?

Thanks for the feedback

#52104
Jul 06, 2011 17:24
Vote:
 

Are you using EPiServer CMS 6 R2?

#52165
Jul 08, 2011 19:41
Vote:
 

I also have problems with the new editor in EPI6! But regarding the version of EPI, is there an easy way to see which version of Epi I have? I know its version 6, but R2? The installation file says "EPiServer CMS 6.1.379.0". Where do I check the R2 part?

#52174
Jul 11, 2011 0:07
Vote:
 
#52188
Jul 11, 2011 11:38
Vote:
 

I am using sing EPiServer CMS 6 R1

#52189
Jul 11, 2011 11:39
Vote:
 

Henrik, you are using CMS 6 R2. 6.0.530.0 is R1 :)

There is no way to see R2 anywhere as I know. But if you go into edit mode, the title of the page should include the version number, e.g. 6.1.379.0. 

#52193
Jul 11, 2011 15:44
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.