Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

EPiServer Mobile Pack



Bee ntrying out the mobile pack for the last couple of days - works fine on the sample alloy tech site.

When I try and add the module to my acvtual site the installation runs into problems. specifically with the MobilePack.episerverdata component. If I uncheck this section during module installation it goes fine. Ive tried taking the .episerverdata file out fo the .epimodule and importing via the admin funtion and it just hangs if I try and verify the file. 

Anyone else had similar problems?  Error message below.

 Importing Setup\MobilePack.episerverdata
An error has occured and the transaction will be rolled back

An unhandled error has occured:
Operation is not valid due to the current state of the object.
When executing

At C:\Program Files\EPiServer\CMS\6.1.379.0\Install\System Scripts\Install ZIP
Module.ps1:131 char:20
+ Add-EPiServerData <<<< -ImportSource $importFilePath '

At C:\Program Files\EPiServer\CMS\6.1.379.0\Install\System Scripts\Install ZIP Module.ps1:12 char:25
+ Rollback-EPiBulkInstall <<<< -ErrorAction SilentlyContinue
System.ApplicationException: A bulk installation has not been started
at EPiServer.Install.InstallationManager.RollbackBulkInstall()
at EPiServer.Install.Common.Cmdlets.RollbackBulkInstallCmdlet.ProcessRecord()
at System.Management.Automation.Cmdlet.DoProcessRecord()
at System.Management.Automation.CommandProcessor.ProcessRecord()   

Jan 17, 2012 10:14

Turns out the episerverdata file was trying to create pages under a page where the new page type was not permitted.

Jan 17, 2012 15:41

Hi Benjamin


Im having the same issue as above.

How did you fix it? Where does it try to create the page? I have given full access to home page and still not working.




Mar 15, 2012 18:42

MobilePack installs under the start page or the root page. Other issues with the installer are either you dont have a GLOBAL vpp folder or you dont have english enabled. Then install on alloy and export pagetypes only and create structure manually.


Mar 15, 2012 19:58

Hi Gareth,

Are you still having the issue? 

You mention that you have given full access to the homepage but have you set the  '

I found the solution by being brave and just going for the import and not doing the verify as it doesnt always return the exact error. 

I'd also check jacobs reply as he is directly involved with the mobile pack project.

Let us know how you get on.




Mar 16, 2012 9:20
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.