Try our conversational search powered by Generative AI!

Epi R2 and TinyMCE stop working properly


Hi, I am struggling with an R2 upgrade and have faced a lot of problems lately.

We use a TinyMCEPlugin to configure Tiny and the CSS. We use: uiEditorCssPaths="site.css" to display the styles in the editor and on the web, note we are not using an editor.css here. (Because EditMenuName is not a valid CSS-entity and wont validate).

This all worked fine until the upgrade!

The style-dropdown has stopped working correctly displaying some unknown "epi_dc" EditMenuNames in the style-dropdown.

The fix was to set uiEditorCssPaths="". This seemed to work fine and all the custom CSS was now displaying in the style-dropdown. Life seemed fine until I discovered that none of the styles are displayed in the editor.

I rewrote the whole solution so it now uses an editor.css and started testing.

The first problem that I discovered was that you can’t reset the style that previously was entered in the text.

Let’s say you add an introduction-text and later on want to add a non-bold text. This fails.

I thought that I could fix this by adding the TinyMCE removeFormat button (eraser). This works fine on Tinys demo site.

Adding it in my TinyMCEPlugin, no luck there, ok adding it on the xhtml property, no luck there ok adding it on an Alloy vanilla demo site NOPE! You can’t add the eraser this must be a bug!

So there I stand with a broken editor and no way to repair it…




Jan 31, 2012 14:40


You're resetting a style by choosing it again in the drop-down.

You must select the text you want to perform the remove format command on.

Jan 31, 2012 15:56


Yes that was the way it worked earlier, but this dont work, I have even tried on a vanilla epi R2. 

I cant figuer out what to do.

I have now noticed that the epilink has dissapeared.

I Have removed my TinyPlugin to be able to track down what is wrong but notting helps, not even iisreset.

 Ok it seems to work on the vanilla, i had a span tag inline destroing the abillity to redo the format.

But how about the Tinysetting in the XHTMLstring property it dosent seem to do anything...

Edited, Jan 31, 2012 16:43

Open up FireBug in FireFox, or similar, and check if some resources gives 404's. Seems like not all files and resources are properly loaded.

Also clear your temporary internet files.

Jan 31, 2012 16:52

Ok, thanx for the advice!


Jan 31, 2012 16:55
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.