Our monthly Virtual Happy Hour is happening this week, Fri Feb 23!

Try our conversational search powered by Generative AI!

Integrating FTS search in CMS 6 issues

Vote:
 

I am getting issues with integrating FTS search in the CMS 6 site. I have installed the FTS search using the link http://world.episerver.com/Blogs/Paul-Smith/Dates1/2011/5/EPiServer-Full-Text-Search-Now-Available-For-CMS-6-R2/ and everything seems to be installed fine. I have made sure I have Windows activation service installed and it is getting to my break point on the service when i run it but when I try to browse to the service I getting an error "No Endpoint Defined"

Also when I try to access the update method I get an error "Method not allowed".

Below is the web.config entry

 <episerver.search active="true">
<namedIndexingServices defaultService="EPiServerFTS">
<services>
<add name="EPiServerFTS"
baseUri="http://test.local/IndexingService/IndexingService.svc"
accessKey="93CC0599-3D95-4B30-8F25-4B8A21D289A0"/>
<!--<add name="{serviceName}" baseUri="{indexingServiceBaseUri}" accessKey="{accessKey}"/>-->
</services>
</namedIndexingServices>
<searchResultFilter defaultInclude="true">
<providers />
</searchResultFilter>
</episerver.search>
<episerver.search.indexingservice>
<clients>
<!--add name="example" description="example" ipAddress="127.0.0.1/8,192.168.0.0/24" ip6Address="" allowLocal="true|false" readonly="true|false" /-->
<add name="93CC0599-3D95-4B30-8F25-4B8A21D289A0" description="local" allowLocal="true" readonly="false" />
</clients>
<namedIndexes defaultIndex="default">
<indexes>
<add name="default" directoryPath="C:\EPiServer\VPP\Proact\Index" readonly="false" />
</indexes>
</namedIndexes>
</episerver.search.indexingservice>
<location path="IndexingService/IndexingService.svc">
<system.webServer>
<security>
<requestFiltering>
<requestLimits maxQueryString="65536" />
</requestFiltering>
</security>
</system.webServer>
</location>

 

Any help will be greatly appretiated.

#56239
Jan 13, 2012 12:29
Vote:
 

Are you using Windows authentication or Forms.  Make sure anyonmous Auth is enabled in IIS.  I have had these hickups as well.  Alot of trial and error.  Let me know if that doesn't work for you. 

#56835
Feb 12, 2012 22:19
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.