Problem with statistics + Logging service (Connection refused)



I've created a report in which I'm getting page hits for the pages I list. Works fine locally on my dev machine, but not in another test environment.

What seems to work on the test environment: 

  • EPiServer CMS Log Service seems to be running just fine. If I start it in DEBUG-mode, it tells me it's listening on two soap.tcp addresses (soap.tcp://localhost/RealTimeAnalyzerView and TimeSpanAnalyzerView) and listening on UDP port 7071.
  • The statistics logging itself runs fine: if I give it a fileAppender instead of the StatisticsUdpAppender, my log files fill up nicely.

I've double and triple checked every single address and port number, and they seem to be correct (They are all default values, really)

Errors I get:

  • If I go to a random page and hit the Statistics-tab, I get "Cannot connect to the log service".
  • If I go to my report (which uses TimeSpanAnalyzerView) and run it, I get an exception and a stacktrace: No connection could be made because the target machine actively refused it ::1:8082. I figure this could be some IPv4 vs IPv6-issue. All config files etc. refer to localhost or However, both ::1 and resolve to the correct hostname, so I sortof doubt that's the problem. When I browse the internet for this exception it's usually due to closed ports or firewalls. I've tried opening TCP port 8082 in the Windows Firewall, but with no luck.

The site is installed on Windows Server 2008 R2 with IIS7. 

Anyone seen this before, or am I simply a champion in the "Works on my machine"-contest?

Jan 05, 2012 15:10

Tried reinstalling the service?

Jan 05, 2012 22:22

I have now. Sadly, it made no difference :-(

I've now tested connecting with telnet as well:

  • If i try to connect to, port 8082, everything works fine.
  • If I try to connect to ::1, same port, telnet can't establish a connection.

IPv6 seems to be disabled everywhere, but EPiServer somehow still resolves to ::1 when connecting to the log service. Might this info help?

Edited, Jan 06, 2012 10:10
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.