Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

EPiServer can't locate system files (virtual paths)

Vote:
 

I have the episerver site working on my development invironment .. but when publishing it the admin url gives me 404

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable. Please review the following URL and make sure that it is spelled correctly.

Requested URL: /Util/login.aspx

First i was creating the site in IIS manually, theni used the deployment center then adding my site files .. but in both cases it can't find the admin path

I have the virtual paths set on episerver.config

<add name="UI" virtualPath="~/secure/CMS/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\application\UI\CMS" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
      <add name="WebServiceFiles" virtualPath="~/WebServices/" physicalPath="C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\application\webservices" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
      <add name="EPiServerCMS" virtualPath="~/secure/CMS" physicalPath="C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\application\UI\EPiServer\CMS" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
      <add name="EPiServerShell" virtualPath="~/secure/Shell" physicalPath="C:\Program Files (x86)\EPiServer\Framework\6.2.267.1\Application\UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />

And i ensured that the physical paths contain the files.

What i am missing here?

#59068
May 18, 2012 14:00
Vote:
 

Does the machine you publish to have EPiServer installed? And also is the machine your publishing to running 64bit version of windows? If not you need to install episerver and then change the virtual paths in the config to go to Program Files with out the (x86).

#59069
May 18, 2012 14:20
Vote:
 

Yes the machine have EPiServer installed and its running 64bit version.

#59070
May 18, 2012 14:37
Vote:
 

What url are you trying to access when you get the 404? And what have you put in your siteURL in the episerver.config?

#59072
May 18, 2012 15:19
Vote:
 

I am trying to access http://mysite.dk/secure/ which redirect to http://mysite.dk/Util/login.aspx?ReturnUrl=%2fsecure%2f

And these is my site settings

siteUrl="http://mysite.dk/" uiUrl="~/secure/CMS/" utilUrl="~/util/"

#59073
May 18, 2012 15:25
Vote:
 

Do you get the 404 when you try access the login.aspx? or is it after you have logged in and it tries to redirect back to /secure ? 

#59074
May 18, 2012 15:53
Vote:
 

I get it when try to access login.aspx

#59075
May 18, 2012 15:56
Vote:
 
Do you have the <location path="util"> in your web.config?

Is the machine a new one? Or does it run other .Net sites already?
#59077
May 18, 2012 16:19
Vote:
 

Petter thanks a lot for you help

I think i found the problem .. i am publishing the website as precompiled site (Sorry i had to mention but i didn't know this was the problem)

Virtualpaths doesn't work in precompiled sites .. So i used this workaround here: http://sunali.com/2008/01/09/virtualpathprovider-in-precompiled-web-sites/

It's working now ... thanks again :)

#59079
May 18, 2012 17:02
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.