Try our conversational search powered by Generative AI!

View mode button in edit mode enterprise site


I have just upgraded an enterprise site from CMS5R2Sp2 to CMS6R1 and further to R2.

All buttons in the upper right corner display their sub menues as they should but the "eye" button for View mode do not display the intended list of site. It works to right click on the page and choose View mode. The browser do not indicate any error with the scripts.

May 04, 2012 16:05

Hi Magnus,

It should take the sites from the sites node in episerver.config. Are all sites configured correctly there?

May 04, 2012 16:32

I'll take a look at them on Monday. Since I upgraded from CMS 5, is there a chance the upgrade script changed them when transforming the new file extracted from the web.config? They seem to work ok otherwise. 

May 06, 2012 14:07


When upgrading Enterprise sites the siteDisplayName="" is empty in the site node. Adding text to it solved the problem!

May 16, 2012 11:56

Mark as solved

May 28, 2012 4:24
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.