Try our conversational search powered by Generative AI!

Language mappings troubles after upgrade .com/sv-Se versus .se



Just upgraded a customer from CMS 6 to CMS 6 R2. Worked OK, after some smaller issues.

One thing I can't get to work again is language mappings. The site is in 20 languages and for some areas a fallback language is used and some pages are localized.

Links that look like this do no longer work:
This gives a kind of 404 (actually an error page that gets an error that redirects to an error page that gets an error and so on...). This link below works fine, though.

The site hosts element of Episerverframework.config has not been changed and the same link worked before the upgrade.

Anybody had this problem (and fixed it)?

Thanks for your help :-)
/ Markus


Jun 15, 2012 14:53

Does the page exist in the requested language or does it have replacement / fallback language rules defined? If not, it should result in a 404. There was previously a bug which made the page fallback to the master language version that was probably fixed between CMS 6 and CMS 6 R2. Might this be what your experiencing?

Jun 18, 2012 13:21

Thanks for your input, Linus,

and yes, I believe you are right. The page does exist in swedish, but swedish is only used in .se, not .com. So a .com requested page with epslanguage=sv-SE did return a swedish page before, but not any more. I created a script to run once that went through all pages in the archive and added a PageLanguageSetting for "en" (our .com language) and set the original language as replacement language.

Thanks for verifying this :-)

Jun 19, 2012 9:53
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.