SaaS CMS has officially launched! Learn more now.

Episerver Composer using SSL


Im currently using Episerver 6 R2 along with Composer. Our client requested we use an SSL when using the CMS so we have attached an SSL certificate to the site in the usual way. Now the CMS runs under HTTPS.

If our client uses the CMS to edit a webpage - and uses the Composer tab they can Add and update a page with no problems.

However, if they enter the Page on the Preview Tab, right click onto the page and choose "Composer - Edit on page" they are taken to the front end and the Composer content blocks are all shown correctly. The page is still under HTTPS.
Next, they edit the content within a Content block > click Save > then click onto Save and Publish - the page refreshes and they are redirected to a HTTP page and are logged out of the CMS and the page hasnt been updated.

We have updated the uiUrl and utilUrl in the epiServer.config file to use https.

We have a UAT server, a Pre Production Server and a Production server and this happens on all sites.

Is there a setting that we have forgotten to update or is this a known issue?


Many thanks



Mar 14, 2013 16:55

Hi, I was wondering if anybody had any ideas on this issue or perhaps you need any more information to help you solve this problem?

Mar 20, 2013 11:06

I just blogged about setting this up. Sounds like you are suffering from some mixed-mode security requests being blocked by your browser.

Mar 25, 2013 11:38
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.