Try our conversational search powered by Generative AI!

Error when installing Enoteca sample


Hi !

I have to use EPiServer Commerce (6 R2 SP2) and to begin I wanted to install the Enoteca sample site.

All went fine until I got the same error as discribed in this topic :
The trouble is that I am using Windows 7 SP1, not Windows 8. And that topic did not help me solving this problem.

As I found nothing to help on the internet, I opened the installation script and tried to figure out this problem :
(EPiServer\CMS\6.1.379.0\Install\Modules\EPiServer Enoteca\Application\Install_Enoteca.ps1)

So the trouble happens when it tries to log in for the first time to Commerce Manager (Mediachase), line 211 :
LoginCommerceManager $cmDomain $defaultUsername $defaultPassword

Indeed, in the LoginCommerceManager.ps1 script, it tries to get a SSO token from the page : 

But the script only get a Mediachase log in page as this SSO token (string variable), an then it tries to access to another page with this SSO token as parameter. And as this SSO token contains all the content of the log in page, it fails (the error GetResponse, with 0 arguments, 404 not found discribed on the other topic).

So desesperatly, I commented out this line 211 and installed the Enoteca sample again : now it seems to work.


So my question is, will the fact that I commented out this be a problem (as it is mentionned in comments that it initialize the database of Commerce Manager) ?
And why this trouble happens ? A collegue of mine has just installed it on its station and it works fine without changes. And I think that I have installed all the requirements.

EPiServer CMS 6 works, Alloy Tech sample works, the installation of EPiServer Commerce 6 R2 SP2 works, but Enoteca sample installation fails.


Thanks for your help.

Jul 10, 2013 12:22

Hi B.

I'm having the same problem and haven't been able to find a fix. I've tried to change some authentication settings in the IIS, to see if that helped, no luck.

Were you able to find a solution for this?

Thank you,


May 09, 2014 13:21
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.