Migration from v4.62 to R2 problem



I am trying to upgrade site from version 4.62 to the latest version 5 R2. The migration is done with the EPiServer CMS Migration Tool 1.1. I am stucked at the step where the filesystem is migrated. There are 2 folders in the v4.62 site called 'upload' and 'docrepository' (Documents) and these are the settings for them in the source site:

<handlers customFileSummarySearch="/docrepository/summary.config">
<handler pageDirectory="False" virtualName="upload" virtualShare="True" type="EPiServer.FileSystem.Handler.VersioningFileSystem,EPiServer">
<customSettings FilePath="/upload/" MaxVersions="7"/>
<handler customFileSummary="/docrepository/summary.config" pageDirectory="False" virtualName="Documents" virtualShare="True" type="EPiServer.FileSystem.Handler.VersioningFileSystem,EPiServer">
<customSettings FilePath="/docrepository/" MaxVersions="7"/>

and here is the settings on the target site:

<virtualPath customFileSummary="~/FileSummary.config">
<clear />
<add name="App_Themes_Default" virtualPath="~/App_Themes/Default/" physicalPath="C:\Program Files\EPiServer\CMS\5.2.375.7\application\App_Themes\Default" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
<add name="UI" virtualPath="~/secure/" physicalPath="C:\Program Files\EPiServer\CMS\5.2.375.7\application\UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
<add name="UtilFiles" virtualPath="~/Util/" physicalPath="C:\Program Files\EPiServer\CMS\5.2.375.7\application\util" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
<add name="WebServiceFiles" virtualPath="~/WebServices/" physicalPath="C:\Program Files\EPiServer\CMS\5.2.375.7\application\webservices" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
<add showInFileManager="false" virtualName="upload" virtualPath="~/upload/" bypassAccessCheck="false" name="Siteupload" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer" physicalPath="C:\WebApps\Save The Children\Development\RB\RB.Web.Vpp\upload" maxVersions="7" />
<add showInFileManager="true" virtualName="Documents" virtualPath="~/Documents/" bypassAccessCheck="false" name="SiteDocuments" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer" physicalPath="C:\WebApps\Save The Children\Development\RB\RB.Web.Vpp\Documents" maxVersions="7" customFileSummary="~/summary.config" />
<filters />

Everytime I start the migration tool I am getting the message:

Versioning VPP with root '~/upload' does not exist

Here is the log from the migration tool:

[12/18/2008 3:24:28 PM][Information] Installed workflow database schema...
[12/18/2008 3:24:29 PM][Information] Installed workflow database logic...
[12/18/2008 3:24:34 PM][Information] Migrating files...
[12/18/2008 3:24:35 PM][Information] Converting native filesystem with root '~/upload/' to versioning filesystem
[12/18/2008 3:24:36 PM][Information] Migrated 0 files/folders, status starting
[12/18/2008 3:25:06 PM][Error] Migration of filesystem ~/upload/ stopped, status stopped, reason: Versioning VPP with root '~/upload/' does not exist
[12/18/2008 3:25:06 PM][Information] Finished converting filesystem '~/upload/'
[12/18/2008 3:25:06 PM][Information] Converting versioning filesystem with virtualName 'Documents'
[12/18/2008 3:25:43 PM][Information] You can now remove old versioning filesystem located at 'C:\WebApps\Save The Children\Development\medlemsportal\docrepository\'
[12/18/2008 3:25:43 PM][Warning] Failed to convert filesystem therefore migration is stopped. Check that target site is running and then run migration tool again and choose continue existing process
[12/18/2008 3:25:43 PM][Information] Migration stop requested
[12/18/2008 3:25:43 PM][Information] Migration stopped

Does anybody have a clue how to solve this problem?

Thanks in advance

Dec 19, 2008 12:59

Solved the problem!!!

The target site (the R2 site) must have application pool with Managed Pipeline Mode set to Integrated.

When it's set to Classic mode didn't worked.
I hope this will help someone else too.

Dec 19, 2008 14:53
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.