Try our conversational search powered by Generative AI!

Setting up local version of Relate site


evening developers,
I'm trying to set up a local version of  a Relate + site, using an already existing user DB allowing existing users to have a play with some of the features.
I get the following stack trace error:
[TypeInitializationException: The type initializer for 'EPiServer.DataAbstraction.UnifiedPathInfo' threw an exception.]
at EPiServer.DataAbstraction.UnifiedPathInfo.Load(String path)
at EPiServer.FileSystem.DefaultAccessControlList..ctor(String path)
at EPiServer.Web.Hosting.UnifiedDirectory.get_DirectoryAC()
at EPiServer.Web.Hosting.UnifiedDirectory.QueryAccess()
at EPiServer.Web.Hosting.UnifiedDirectory.QueryDistinctAccess(AccessLevel access)
at EPiServer.Web.Hosting.VirtualPathVersioningProvider.GetDirectory(String virtualPath)
at EPiServer.Web.Hosting.VirtualPathHandler.InitializeProviders(ProviderSettingsCollection providers)
at EPiServer.Web.InitializationModule.InitializeVirtualPathProviders(VirtualPathElement vpElement)
at EPiServer.Web.InitializationModule.Initialize(EPiServerSection config, Settings settings, ConnectionStringSettingsCollection connectionStringSettings)
at EPiServer.Web.InitializationModule.StaticInitialization()
at EPiServer.Web.InitializationModule.Application_BeginRequest(Object sender, EventArgs e)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

[Inner exception TypeInitializationException: The type initializer for 'EPiServer.CacheManager' threw an exception.]
at EPiServer.StaticCacheKey..ctor(String keyName)
at EPiServer.DataAbstraction.UnifiedPathInfo..cctor()

some more points:
 - The Unified file paths have ben used for other Episerver applications and work fine
 - the DB copnnection for the DB has been tested

I've read an article at (SP3 Upgrading problems

I tried Martin Kulov's module, but still no success.
Has any body encountered any issues?
have any suggestions?
the Episerver dlls in Relate + are version 5.2.375.7

Thanks in advance

Feb 23, 2009 19:35

Hi Efe,

There seems to be some issue with the CMS, probably in the CacheManager. It's hard to know exactly what it is. I recommend you to enable logging (see see if you can find out something more.

Best regards,

Feb 24, 2009 11:50

Thanks for that idea Tom. I've enabled logging and the recurring error is:

2009-02-25 13:00:40,277\t(null)\t1.2.5 Unhandled exception in ASP.NET
System.MissingMethodException: Method not found: 'Boolean System.Web.HttpRuntime.get_UsingIntegratedPipeline()'.
at EPiServer.Web.StaticFileHandler.BeginProcessRequest(HttpContext context, AsyncCallback callback, Object state)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

The edit section loads but none of the css, javascript or images are displayed. Trying to access any of the files within the Application directory via a browser leads to the 500 internal server error and error above being displayed.
The machine is a Windows Server 2003, .NET 3.5 SP1, IIS 6.0.

On the forums I've sen that the 'get_UsingIntegratedPipeline()' refers to IIS 7, but I'm using IIS 6.0

any thoughts?

Feb 25, 2009 16:17

You need to install SP1 of .NET Framework 3.5


Mar 12, 2009 20:40


This method is available in the System.Web.dll of the .NET framework 2.0.50727.3053 (ie after .NET 2.0 SP2).

This problem happened to me even though I had .NET framework 3.5 SP1 on Vista Enterprise. I then borrowed System.Web.dll version 2.0.50727.3053 from my colleague and dropped in the GAC and restarted the IIS. It worked.



Apr 12, 2010 15:39
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.