SaaS CMS has officially launched! Learn more now.

Error when trying to create new user from admin mode



 I'm using the standard Relate+ installation with all the templates. The site works fine but when i try to add a new admin user from admin mode i get the following error:

at EPiServer.Common.Web.Authorization.MembershipProvider.get_MinRequiredPasswordLength() at System.Web.Security.Membership.get_MinRequiredPasswordLength() at EPiServer.UI.Edit.UserMembership.ValidatePassword() at EPiServer.UI.Edit.UserMembership.SaveMembershipUser() at EPiServer.UI.Edit.UserMembership.SaveButton_Click(Object sender, EventArgs e)

Unexpected Provider error! This may be caused by invalid combination of Role and Membership providers.

Anyone seen this before?

-Kjetil Simensen

Mar 23, 2009 11:22

I have seen a similar error several times, and the problem has been that the email address is duplicate (so the error message seems very generic). But your stack trace implies that it fails to read the minimum required password length. Check the minRequiredPasswordLength attribute on your membership provider if it has a valid value etc.

Mar 23, 2009 15:33

Hi Magnus, 

I tried adding the minRequiredPasswordLength attribute but with no success. I've also tried using different passwords and still same error.

Any ideas are appreciated :)

Edited, Mar 23, 2009 15:40


Just out of curiousity, what membershipprovider are you using?  

Either way, try using Community tab -> System Settings -> Groups/Users -> Add User instead.


Mar 23, 2009 15:52

That did the trick, Joel! thanks :)

I'm completly green when it comes to Relate+ and thought there were only one way of adding users (the old episerver way). Is the old way through admin mode supposted to work when using the out of the box demo template site?

Mar 24, 2009 9:37

As far as I know the EPiServer.Common.Web.Authorization.MembershipProvider (the default provider which wraps around EPiServer Communitys own security system) supports creating new users but it doesn't support retrieval of information such as minimum password length. As it seems that the EPiServer CMS admin mode validates minimum password length adding new users that way won't work with that provider :(

Edited, Mar 24, 2009 10:33

But there is still hope... :)


As of the current hotfix version of EPiServer Common (where the mentioned MembershipProvider resides), the previously unimplemented properties are now implemented.

Mar 27, 2009 15:21
Sweet! :)
Mar 27, 2009 15:28

I had the exact same error but the wrong e-mail was not the reason.


Be sure to check the logfiles written out by EPISERVER, there you have a good chance of figuring out what the reason for the error is.  In my case, the transaction log of the database was full...  I shrank the log and voila, everything worked fine again! :-)

Nov 14, 2011 17:43
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.