SaaS CMS has officially launched! Learn more now.

Button for inserting/edit link sometimes dissapear in TinyMCE?


We are using EPiServer 6 R2 and have a strange problem.
The button in toolbar for inserting/editing link (the one with a globe) sometimes dissapear from toolbar,  for several editors.

I have never encountered the problem myself but some editors explained the problem to me.
No changes are made to the "default" settings of the editor.

We can not recreate the problem in any managed way.

Is this a known issue or has someone else reported a problem like this?


Sep 29, 2011 9:23

Sorry, I haven't heard of this problem. It disappears randomly? Or is it always missing for some of the editors?

Oct 13, 2011 8:54

We have the same problem in one of our sites after upgrading to R2. The link button is missing and also the browse for file button in the insert image dialog.

It seems to affect IE7, IE8 and IE9 32-bit version. The problem is solved in IE9 by hitting Ctrl+F5 in the 64-bit version. Then both versions work.

Have not found a solution for IE7 or IE8. The problem has also been seen in Chrome and Safari. Firefox works fine.



Oct 21, 2011 22:07

I've found out now that some of our editors are using Firefox! When they changed browser to IE9 it worked again?!

But we also had problems with IE9, I will try Ctrl +F5 next time.

It's not always the same user and it dissapears randomly...


Oct 24, 2011 14:41

Got it! Changing the DNS record from CNAME (Alias) to A-record solved the problem.

Nov 02, 2011 13:40

Geir: Did you ever find out WHY changing the DNS record solved the problem?

Dec 20, 2011 10:14

I've encountered this problem too and in addition to the link button, also the dynamic content button is missing for the editors having problems.

I haven't been able to test with the DNS record modification yet, but hopefully that will solve it. In the meantime, did anyone find out anything more about this?

Mar 29, 2012 9:38

Could try this, which partner sent in for a similar problem (windows auth)
        <deny users="?" />

in <location path="util">

Mar 30, 2012 13:58

Thanks, Paul. It turns out however, that the DNS change seems to help at least a few of the editors (haven't confirmed with all). However, the buttons now disappeared for those who had them before... Clearing the browser cache seems to fix that problem though, so I guess something happened in the scripts when the DNS change was made.

Mar 30, 2012 14:05

I also had som difficulties with this but can confirm that Pauls solution works - at least i did for me. I used "allow roles" but the effect was the same

The problem was that it worked intermittently for us. We finally identified this as having to do with the fact that an administrator *had* been logged into EPiServer on the same client. Somehow it was cached and when the cache expired it stopped working.

Mar 30, 2012 14:22

I have experienced the same problem on our intranet site after upgrading from 6 to 6R2. The site uses windows authentication. Neither of the solutions mentioned in earlier posts have worked, has anyone found another solution to this problem?

Edited, May 19, 2012 9:25

I have the exact same problem as Matt explains. Any solutions yet?

Apr 29, 2013 13:26

We have the same issue on a new installation of 6R2 that is being used as an Intranet.

I have tried Paul's suggestion but all that happens is that the panels (treeview and main editing panels) within edit mode shrink and I am unable to do anything.

I am unable alter the DNS as the site is being accessed via IP address.

What I have found is that it appears to be nothing to do with what browser is being used (I can replicate the issue on all of them).  As Jerry stated; if an administrator logs in, then the button appears.  After an idol period the button dissapears again.  I even get this is the admin user doesn't do anything.  Logging out and back in again as the administrator brings the button back.

We are using multiplexing across 2 active directories with windows auth.

Any help would be greatly appreciated.


Jun 14, 2013 15:59

We had this issue, and resolved it. Thought I would add our findings here as this post came up in my searching attempts and may help some one else in the future


I believe its because the logged in user is not a member of the CmsEditors or CmsAdmins mapped role.

In our project we use single sign on and the group names are prefixed with the domain (eg mydomain\intranetAdmins, mydomain\intranetEditors)

Adding these role names to the MappedRole in EPiServerFramework.config worked.


Default EPiServerFramework.config

<add roles="WebAdmins, Administrators" mode="Any" name="CmsAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" />
<add roles="WebEditors" mode="Any" name="CmsEditors" type="EPiServer.Security.MappedRole, EPiServer.Framework" />

Working EPiServerFramework.config

<add roles="WebAdmins, Administrators, mydomain\intranetAdmins" mode="Any" name="CmsAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" />
<add roles="WebEditors, mydomain\intranetEditors" mode="Any" name="CmsEditors" type="EPiServer.Security.MappedRole, EPiServer.Framework" />


Hope that helps!


Jul 08, 2013 2:04

Thank you for that input Corey, but in my case this was not the problem. The editors were all placed in the correct groups. CmsEditors were also the only ones allowed to enter the edit mode, so that was rather obvious. But anyway, it seems that this problem has multiple potential reasons.

Jul 08, 2013 10:02

I have tried all of the "solutions", but no change. 

If I remove the cache the button appears for me, but at some point it vanishes again. I am a cmsadmin so logging in with a admin user doesnt really help me.

Sep 25, 2013 15:21

Had the same problem. My solution was to change one of the CMS core files:

C:\Program Files (x86)\EPiServer\CMS\6.1.379.0\Application\Util\javascript

Open system.aspx

remove the access check in the function ResolveUrlFromUI

<% if (EPiServer.Security.PrincipalInfo.HasAdminAccess ||
EPiServer.Security.PrincipalInfo.HasEditAccess ||
EPi.ResolveUrlFromUI = function(url)

{ return "<%=EPiServer.UriSupport.ResolveUrlFromUIBySettings("")%>" + url; }

<% }%>

Oct 17, 2014 15:29
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.