Try our conversational search powered by Generative AI!

EPiImageProperty and EPiImageGallery not working in EPiServer 7.5 with dojo framework


I am following below article

EPiImageProperty and EPiImageGallery property rendering properly in on page edit mode but not able to update image title, description and LinkUrl of EPiImagePropery when clicking on “Edit Info” when we edit existing EPiImage Property.

Also in EPiImageGallery Property , able to add first image, but later unable to add second image or so.

Below are the EPiImage integration steps followed on sample site.

1) I have created a sample site solution and in which I added EPiImage Project So that I can reference it and use debugging function if required. As per instructions, I have added Client Resources and module.config in my web project.

Step 1

2) As per instruction of article, I have added other required resources in side project like ClientResources and module.config.

Step 2.1

Step 2.2

3) Now I have create a page type with name of ‘StartPage’ in side Models of web project and then I have added EPiImageProperty and EPiImageGalleryProperty within that page type as per instructions given in article . After adding these properties I built project with success.

Step 3

4) I run project and logged in CMS Panel then found both properties to edit or add.

Step 4

5) I was able to add new image and relevant info like title, description and link.

Step 5

6) Now issue was aroused that I cannot edit any image info like title/description/link. Popup will open every time and but it will not trigger for published/AutoSaved and finally I cannot save changes to the server.

Step 6

I have checked that No error is occurred in side firebug of Mozilla at time of pressing ok button.

7) In case of ImageGalleryProperty, I can add only one image in collection. I cannot add more than one image in collection.

Step 7

So, let us know if any one facing same issue with EPiImage on EPiServer 7.5 ( using WebForms. Your help will be highly appriciated.

Thank you.

Regards, Yagnik Jadav

Nov 20, 2014 12:28

Hi  Yagnik,

This property is dojo-based for the back-end, therefore, using it on web form or mvc EPiServer shouldn't be a solution. Message me if you need help on this, will be a lot easier once I could see the clients script log on your solution.


//Tuan Truong

Feb 04, 2015 3:15

Hi  Yagnik,

The issue is  now fixed and checked in to git hub .


Feb 12, 2015 4:07

Have a project that went from EPiServer.CMS.UI 8.6.2 to 11.13.2 and have troubles getting EPiImage running after the upgrade.

It worked in the older version using the concepts above and

Anyone suceeded getting it to run on a more modern version?

This site's module.config after upgrading (don't know much about it...)

<?xml version="1.0" encoding="utf-8" ?>
<module loadFromBin="false">
		<add assembly="EPiImage" />
		<add assembly="SomeClient.Web" />
		<add name="epi-cms.widgets.base" path="Styles/displayresolutions.css" resourceType="Style" isMinified="false" />
		<add name="" path="Styles/imagegallery.css" resourceType="Style" />
		<!-- Add a mapping from alloy to ~/ClientResources/Scripts to the dojo loader configuration -->
			<add name="someclient.web" path="Scripts" />
			<add name="app" path="Scripts" /> 
			<add name="epiimage" path="Scripts/EPiImage/" />
		<add name="SomeClient" path="~/" />
		<add name="someclient" path="Scripts" />
	<clientModule initializer="app.ModuleInitializer">
			<add dependency="CMS" type="RunAfter" />
			<add name=""/>

The error I'm getting in Edit Mode:

404 from /EPiServer/Shell/11.13.2/ClientResources/epiimage.editors.EPiImage.js

In the working older branch I see the correct path of the file and the URL is starting with /ClientResources

Might just be something with module.config and some breaking change?

Jan 29, 2019 16:35
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.