SaaS CMS has officially launched! Learn more now.

Path to admin gets messed up after 7.5 upgrade

Vote:
 

Just did a upgrade from 7.1 to 7.5. Got all the files migrated and site works fine except for one issue.

Going to edit only gives me the topbar. The rest is empty (gray). Checking the consol gives /UI/javascript/system.js 404 (Not Found)

The same goes for trying to go to the admin mode by clicking the ribbon. It will try and go to /UI/Admin/Default.aspx

Question is why is it trying to go to /UI? 

When checking the link for Edit it shows the correct path (/epiui/Cms/)

If I go directly to /epiui/Cms/Admin/Default.aspx I get an error: 

The file '/UI/MasterPages/Frameworks/Framework.Master' does not exist.

So it 

 

<episerver.shell>
<publicModules rootPath="~/modules/" autoDiscovery="Modules" />
<protectedModules rootPath="~/epiui/">
<add name="Find">
<assemblies>
<add assembly="EPiServer.Find.Framework" />
<add assembly="EPiServer.Find.Cms" />
</assemblies>
</add>
</protectedModules>
</episerver.shell>

And Packaging 

 

<add name="ProtectedAddons" virtualPath="~/epiui/" physicalPath="[appDataPath]\Modules" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />

 

Anyone got any ideas?

 

#83054
Mar 25, 2014 11:42
Vote:
 

Hi,

Exactly what version of EPiServer 7.5 are you running now? Could you check the File Version for EPiServer.dll?

#83055
Edited, Mar 25, 2014 12:08
Vote:
 

7.5.1003.0 for the bin stuff and 3.0.1097 for the CMS parts in Modules

 

#83065
Mar 25, 2014 12:56
Vote:
 

Ok, when I installed 7.5.1003.0 the following was added below <protectedModules>:
<add name="Shell"/>
<add name="CMS"/>

Maybe something failed during installation of NuGet packages (if you installed it through NuGet that is)?

#83067
Mar 25, 2014 13:03
Vote:
 

Yep rand the Nuget (don't think there is any other way) but seems I didn't get that config update. 

Tried adding it but saddly no difference.

#83069
Mar 25, 2014 13:09
Vote:
 

Not sure if it will fix the problem, but I would try getting the latest NUGET packages and run the Move-EPiServerProtectedModules command as described in this blog post (http://world.episerver.com/Blogs/Khurram-Hanif/Dates/2014/3/EPiServer-76-Protected-Site-Add-Ons-location/). Doing that, you will be on the latest version, and hopefully it might just fix your issue as well.

#83072
Mar 25, 2014 13:26
Vote:
 

Running Owl so can't go past 7.5 atm... but will give that a go if nothing else comes to mind when they update the owl package.

Or will that just update the ui?

#83075
Edited, Mar 25, 2014 13:40
Vote:
 

Updated to 7.6 but still the same issue.

 

So I redid the upgrade and I'm getting the same error in edit mode but this time the Migration tool gets an error that seems connected 

The modules finder couldn't find a directory at '~/epiui/Shell'
Parameter name: moduleResourcePath


at EPiServer.Shell.Modules.ModuleFinder.GetModuleInDirectory(String routeBasePath, String moduleResourcePath, IEnumerable`1 configuredAssemblyNames, AutoDiscoveryLevel discoveryMode, String configuredName)
at EPiServer.Shell.Modules.ConfigModuleProvider.GetConfiguredModules(ModulesElementCollection configuredModules)
at EPiServer.Shell.Modules.ConfigModuleProvider.GetModules()
at System.Linq.Enumerable.<SelectManyIterator>d__14`2.MoveNext()
at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
at EPiServer.Shell.Modules.ShellModule.MergeDuplicateModules(IEnumerable`1 modules)
at EPiServer.Shell.ShellInitialization.Initialize(InitializationEngine context)
at EPiServer.Framework.Initialization.ModuleNode.Execute(Action a, String key)
at EPiServer.Framework.Initialization.InitializationEngine.InitializeModules()
at EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType)
at EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType)
at VppMigrationTool.Util.SiteProxy.InitalizeEPiServer(String webConfigPath) in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Util\SiteProxy.cs:line 52
at VppMigrationTool.Util.SiteProxy.Initialize(String destinationPath, String virtualDirectory) in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Util\SiteProxy.cs:line 129
at VppMigrationTool.Util.SiteProxy.Initialize(String destinationPath, String virtualDirectory)
at VppMigrationTool.Converter.get_RuntimeProxyWrapper() in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Converter.cs:line 52
at VppMigrationTool.Converter.FillSiteData() in d:\Builds\132\EPiServerCMS Modules\VppMigrationTool\Sources\C\TFS\VppMigrationTool\Converter.cs:line 101

 

Does the stracktrace give any one Ideas?

#83184
Mar 27, 2014 11:45
Vote:
 

Hmm.. could it be that I need to upgrade to 7.5 first and run the tool there before going to 7.6?

#83185
Mar 27, 2014 11:53
Vote:
 

I'm not sure exactly what is wrong in this case but I want to verify something that is not entirely clear from what has been said so far:

When upgrading from 7.0/7.1 to 7.5 did you first do the upgrade to original 7.5 release in EPi Deployment Center and after that installed the latest 7.5.x release using nuget? Did the site work after the initial 7.5 upgrade? (The original 7.5 release is the intended starting point when installing the later 7.5.x releases.)

#83190
Mar 27, 2014 12:19
Vote:
 

Right might have been a bit unclear.

 

Yes I downloaded the 7.5.3x from world and ran the upgrade script  from deployment center. Then did the nuget upgrade suff. Didn't check the site inbetween but will get right on it.

#83203
Mar 27, 2014 13:25
Vote:
 

Doing the Migration on that version worked.

But still get the same issue with the UI paths.

 
#83208
Mar 27, 2014 14:39
Vote:
 

Have you installed the nuget package for the UI as well? I thinkt there was a package for that as well. Someone wrote a post about that somewere :)

#83211
Mar 27, 2014 15:07
Vote:
 

Not sure what package your refering to. But I did run the Upgade/disable add-ons script and now after you comment I also updated the EPiServer.CMS.UI nuget package but no difference.

#83222
Mar 27, 2014 15:42
Vote:
 

I think it was that one, sadly.

#83225
Mar 27, 2014 16:44
Vote:
 

To check that it's not a corrupt download on my machine I created a fresh 7.5 site via the Deployment Center.

 

On this one edit and admin works. 

I have compared all the files in Modues and the EPi dll:s in bin for my site and the new 7.5. Both have the same versions and files.

#83226
Mar 27, 2014 16:52
Vote:
 

Been trying this backwards and forwards for a while now.. and from what I can figure out the issue has to do with some of the wiring of the site. 

For my  [appDataPath]\Modules folder contains the right files and I can access em if I go directly to the URL say,  /epiui/cms/javascript/system.js (ie the file that isn't loading with in edit)

But when the interface tries to load the resources it tries to go to: 

/ui/javascript/system.js

Same for admin, I can go to /epiui/cms/admin/default.aspx but from the GUI the link is ui/admin/default.aspx

And when I go to admin with the right URL it tries to load the masterpage from the /ui/MasterPages/Frameworks/Framework.Master

#83232
Mar 27, 2014 17:13
Vote:
 

Fixed!

 

So the issue was that my episerver.config didn't get updated. So I had <site> and <sitesettings> elements in there when I should have had <applicationsettings>

 

#83245
Mar 28, 2014 6:55
Vote:
 

There is a newly registered bug (#112774) on this issue, which is still in active state. This bug can occur on upgraded sites (7.6.3) when running vpp migration tool, mirroring etc.  

#83247
Mar 28, 2014 7:53
Vote:
 

Great thanks. A nice to have feature for the bug fix would be to make the <site> and <sitesettings> element not valid in the config anymore. That way you would get a nice error about it =)

#83250
Mar 28, 2014 8:11
Vote:
 

Nice to know

#83253
Mar 28, 2014 9:31
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.