Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

more then one content model is assigned


Dear community,

I am installing episerver 7.5 cms and commerce. i got the following error:

Error - More than one content model is assigned the guid 7e932eaf-6bc2-4753-902a-8670edc5f363

Does anyone has a clue what went wrong?


Mar 21, 2014 12:12

You probably have two content types that uses the same guid. I would do a search in your solution for "7e932eaf-6bc2-4753-902a-8670edc5f363".

Each content type must have an unique guid

Edited, Mar 21, 2014 12:21


That is a bug when you install both the Alloy sample templates in CMS and the Commerce sample templates.

You can work around it by replacing the guid for the ImageFile model. They are unfortunately the same for both sample packages.


Per Gunsarfs

Mar 21, 2014 13:23

Thank you very much for replying. 

Can i replace this?

ExampleEPiServerSite ; wwwroot ; Models ; Media ; ImageFile

[ContentType(GUID = "0A89E464-56D4-449F-AEA8-2BF774AB8730")]

In which GUID should i replace it?

Mar 21, 2014 13:44

Yes, replace the guid in the [ContentType] attribute with another (random) guid.

Mar 21, 2014 14:12

Thank you very much it worked! Problem solved :)

Mar 21, 2014 14:33
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.