Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

EPiServer 7.5 Migration Tool


Hi all,

We are currently trying to migrate VPP files from an EPiServer 6 R2 site to a new instance of an EPiServer 7.5 site. 

We were hoping that we could make use of the EPiServer migration tool to achieve this.  I realise that this isn't the traditional way of using the migration tool as I haven't upgraded the existing site using the deployment center.

However despite this, I have the migration tool up and running by editing the web.config in our new 7.5 site by adding the following code in   :

      <>clear />
      <>add name="ProtectedModules" virtualPath="~/EPiServer/" physicalPath="Modules\_Protected" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />
      <>add showInFileManager="true" virtualName="Page Files" virtualPath="~/PageFiles/" bypassAccessCheck="false" indexingServiceCatalog="Web" physicalPath="(** path to directory **)" name="SitePageFiles" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer" />
      <>add showInFileManager="true" virtualName="Global Files" virtualPath="~/Global/" bypassAccessCheck="false" indexingServiceCatalog="Web" physicalPath="(** path to directory **)" name="SiteGlobalFiles" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer" />
      <>add showInFileManager="true" virtualName="Documents" virtualPath="~/Documents/" bypassAccessCheck="false" maxVersions="5" physicalPath="(** path to directory **)" name="SiteDocuments" type="EPiServer.Web.Hosting.VirtualPathVersioningProvider,EPiServer" />

I have also created classes in the new 7.5 project to migrate the different file types.

When open the migration tool, I can see the Virtual path providers and also the content types found. However, when I run the tool I recieve the following logs:

Converting VPP: SiteGlobalFiles
Converting VPP: SiteDocuments
Converting files in /Global/ [6]
Converting files in /Documents/ [5]
Converting folders in /Documents/ [5]
Converting folders in /Global/ [6]
No EPiServer Find stores to convert found
Directories: 2
Files: 0
ContentFolders: 0
FileContent: 0
Blobs: 0
VirtualPathProvider named 'SiteGlobalFiles' was successfully converted and removed from site config
VirtualPathProvider named 'SiteDocuments' was successfully converted and removed from site config

As you can probably see, no files are migrated across but the directories are.

I suppose there are two parts to the my question here.

1) Will this approach work when I'm not upgrading an existing 6 R2 site, just migrating the VPP?

2) If the answer to the previous question is yes, is there any reason why the files aren't migrating across?

Thanks in advance,


Jul 24, 2014 14:48

It will not work for VirtualPathVersioningProvider since metadata for the files/folders are stored in the old database (ObjectStore), for VirtualPathNativeProviders it would work. 

So to get it to work you would need to initialize object store against your old database. Theoretically you could do this by adding configuration to your site like below (have not tried this):


When the migration is done you should remove the configuration. 

Jul 25, 2014 8:50
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.