Try our conversational search powered by Generative AI!

Maby a stupid and simple question of foldericon i tree in edit


We are under upgradering 7.1 to 7.5 for a site and now we noticed that the pages that we use as folders in the tree does not have the foldericon any more.

I might be stupid but I cannot find out how to get the icon back, anyone smarter than me that knows how to do that.

Aug 27, 2014 10:31

In 7.5, container pages are now templated implementations instead of system types. You need to add a little config: 


Aug 27, 2014 10:50

I read it in the breaking changes but maby my mind was somewhere else....

Got it now, so thanks!

Aug 27, 2014 11:08

Sometimes I came across an issue that icons really are not shown (for non of the content types). They do show up once again after app pool recycle. I speculate on some cache or similar animal..

Aug 27, 2014 23:12

Having the same issue as Valdis or kind of. It used to work with registering an interface in the descriptor but doesn't work anymore. Seems to need a concrete class (didn't have the time to ilspy the episerver source). But the moment I remove the interface registration and use a class I get my edit mode icons correct in the tree view.

Sep 01, 2014 11:05

Try with interface code to recycle pool. It worked for me.

Sep 01, 2014 11:10

Valdis, I tried that but no go. Running patch 29 on the site but had the same issue already with patch 27.

Sep 01, 2014 11:12

If you are still having issues with this and have a clear repro, please contact support to create a bug for this.

Sep 09, 2014 10:05
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.