It's great the way that EPiServer updates can now be handled through Nuget packages.
However, there is a small issue that has been causing me some bother on the project I am currently working on. I can work around this problem, so this post is more of a request than an issue that needs resolving immediately.
I have a third party package in my solution that has a dependency on Newtonsoft.Json >= 6.0.
However, all of the EPiServer packages specifically require Newtonsoft.Json to be < 6.0.
The result is that when I have the latest Newtonsoft.Json package installed (6.0.4), and try to update EPiServer packages, it fails because my current Newtonsoft.Json package is too high.
My workaround to this is to remove the Newtonsoft.Json entry from my package.config files, which then allows me to update the EPiServer packages. Doing this then installs Newtonsoft.Json 5.0.8 packages, so afterwards I have to go back through my package.config and .csproj files to change the references from 5.0.8 back to 6.0.4. With 7 projects in my solution having dependencies on EPiServer and Netwonsoft.Json packages, this is a tedious task.
My site and EPiServer run without any issues on the latest Newtonsoft.Json, so please could I ask that this dependency is updated to allow more recent versions?
Similarly, I notice there is an update for Log4Net which I can't install because EPiServer has a strict dependency on version 1.2.10. There's also a package for 'DotNetZip' which can't be updated. StructureMap could be updated to the latest without a problem.
My real issue is the Newtonsoft.Json dependency, if it could be fixed this would make me happy.
That would make me happy as well.
That makes three of us!
I vote for it as well.
We already have another thread going on the same subject, the title is just a little bad.