Try our conversational search powered by Generative AI!

VPP migration tool fails when upgrade 7.0=>7.5


I've been using the VPP migration tool several times without any issues but in the current project when trying to upgrade it fails without any exception at all, just shuts down, and that is after converting lots of files.

The only two differences I can see in this project is that it was upgraded originally from CMS 6, and that the VPP consists of HUGE amounts of files.

I reflected up the exe file, rebuilded it as a project, compiled, run and debugged it, and we got stuck in the Convert() method, the inner exception of the error is:

Objektet /b59e0495_292c_48cc_9036_d7aa3b542bcd/3pxurinetnbst3_wfebbckz+_5.rem har kopplats från eller så finns det inte på servern.

Here is an explanation of the error, unfortunately it doesn’t give me a clue.

I've tried with both VPP and DB at my local machine.

The last row in the log file for the tool was:

Converting folders in Documents [84327]

And the 84327 ID is of type SysContentFolder.

The stack:

   vid VppMigrationTool.Util.StatusWriter.Write(VppMigrationTool.Util.StatusEventArgs)
   vid VppMigrationTool.Util.StatusHandler.SiteProxyInstance_StatusEventHandler(VppMigrationTool.Util.StatusEventArgs)
   vid VppMigrationTool.Util.VppConverter.HandleExcpetion(System.Exception, Boolean)
   vid VppMigrationTool.Util.VppConverter.Convert()
   vid VppMigrationTool.Util.SiteProxy+<>c__DisplayClass2.b__1(System.Object)
   vid System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   vid System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   vid System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   vid System.Threading.ThreadPoolWorkQueue.Dispatch()

One thing as well is that after an upgrade I couldn't see the block tree, that was because of two things, in the original episerver.config the globalBlockFolderId and siteBlockFolderId was incorrect, and that I needed to tick the "use site specific assets" in Admin mode, and the folder that I did specify was the one with ID 84327. After the upgrade script it added a new row in db with a SysContentFolder typef for a block, don't know why the script does so?

Any help much appreciated.


Aug 18, 2014 17:44


I'm facing the exact same problem, except the thing with the block tree. Did you ever find a solution? Or anyone else? The migration I'm trying to do has crashed four times, with different data amount that was successfully migrated. 


Nov 18, 2014 10:08

Now I've had two successful migrations in a row. The thing I did was to change the swap file/page file in windows 7 to be placed on an external disc (my internal disc's free space was 18GB).

Nov 21, 2014 8:46

I had this same error and managed to solve it by modifying the source code of the VPP Migration Tool a little.

The tool contains two classes that derive from MarshalByRefObject: SiteProxy and StatusWriter (which throws the exception).

I fixed the error by adding the following method override to StatusWriter:

public override object InitializeLifetimeService()
  return null;

This override is already present in SiteProxy, but not in StatusWriter. For me, this solved the timeout problem.

Nov 16, 2015 10:01
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.