SaaS CMS has officially launched! Learn more now.

Remote event configuration

Vote:
 

I'm having some trouble getting remote events over TCP to work. The site is installed on two servers, one front server in DMZ where the EPiServer interface is disabled, and one app server in the internal network where it is enabled.

On the broadcasting server (the app server), I've added the following to the web.config (site names and IPs have been replaced with dummy values):



      

On the listening server (the front server), I've added this to web.config:


      
  	
      
         
      
        
      
    

Both web.configs also contain a TCP binding:


          
            
          
        

The problem is that when I update a page on the app server, the changes aren't reflected on the front server until I force a cache invalidation, e.g. by touching the web.config  (I've checked that the ports are accessible using iperf). According to the documentation (http://world.episerver.com/documentation/items/developers-guide/episerver-cms/75/event-management/wcf-event-management/) the configuration above should suffice. What am I missing?

#118061
Feb 26, 2015 15:49
Vote:
 

Hi William,

The setup seems to be right. Just to be sure I would try with the ip instead of loalhost on the services.

Beond that I would try and sniff the traffic and see if the events are comming through. Wireshark is what I have used before. https://www.wireshark.org/ 

#118065
Feb 26, 2015 16:18
Vote:
 

Hi Petter,

Thanks for your reply. I actually started out with IP, but changed to localhost to see if it worked better. 

Are there any packets in particular that I should look for in Wireshark, i.e. how do I identify packets coming from the EPiServer remote event service? 

#118067
Feb 26, 2015 16:23
Vote:
 

Try to run netstat on your servers and look for ports 13000 and 13001.

I would also check that your IIS site name is exactly the same as Site1 and Site2, exactly. 

#118079
Feb 26, 2015 17:54
Vote:
 

Hi Christian,

I've run netstat, and there doesn't seem to be anything listening on ports 13000 and 13001. Do we have to do a full install of EPiServer on the servers (currently we've only deployed the EPiServer DLLs along with the sites), or is there something else that we need to active/enable somehow?

#118114
Feb 27, 2015 11:12
Vote:
 

What version of EPiServer CMS are you running? 

Any version below cms 7.5 you need to do a full install. 

#118116
Edited, Feb 27, 2015 11:22
Vote:
 

EPiServer 7.5 (update 49-ish)

#118124
Feb 27, 2015 12:23
Vote:
 

Then you should not have install anything on your servers. Just copy your site.

If you have made sure that Site1 and Site2 is the exakt name of the websites name in IIS then check the windows firewall and open up ports 13001 and 13000 if thats not already done. 

Monitor your progress in netstat. 

#118126
Feb 27, 2015 13:05
Vote:
 

Just managed to solve this now, turns out there were two factors:

  • As Christian mentioned, the site name (Site1, Site2) has to match the IIS name exactly.
  • When I did this, ASP.NET threw an exception (The TransportManager failed to listen on the supplied URI using the NetTcpPortSharing...). The solution was to enable the following Windows services: Net.Tcp Listener Adapter and Net.Tcp Port Sharing Service.
#118184
Edited, Mar 02, 2015 10:38
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.